We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Excel Chart Label Spacing

Thread ID:

Created:

Updated:

Platform:

Replies:

95463 Jul 9,2010 01:02 PM UTC May 24,2011 06:33 AM UTC ASP.NET Web Forms (Classic) 4
loading
Tags: XlsIO
Swapna Gogineni
Asked On July 9, 2010 01:02 PM UTC

I am creating a chart to show data over a time period. I have data for every month for several years. When I plot the chart in Excel 2007 all the date labels show up (barely can read them since they overlap each other, too many labels). In excel you can open the format axis and set the major unit to 'Auto'. Is there a way to do this using XlsIO. I tried the TickMarkSpacing = 3 but that applies for all the charts and it is not necessary that all chart spacing are to be adjusted. Some charts are plotted for only a few months and the labels are fine, its the charts that show data for several years that have the issue.

Attached is a screenshot of the chart. Please let me know.

Thanks,
-Swapna



Syncfusion Chart_82d5ab6f.zip

Swapna Gogineni
Replied On July 9, 2010 01:06 PM UTC

Minor correction. Using TickLabelSpacing = 3 not TickMarkSpacing.

Thanks,
-Swapna

Geetha M [Syncfusion]
Replied On July 12, 2010 06:18 AM UTC

Hi Swapna,

Thank you for your interest in Syncfusion products.

Currently it is not possible to set category axis as Automatic. However, I have logged this as a issue internally. Could you please create a new incident in Direct Trac so that we can send you the details?

Regards,
Geetha

Kathy Gray
Replied On May 23, 2011 09:57 PM UTC

Has this item been fixed yet? I have the same exact problem.


John Bowlin Bosco K [Syncfusion]
Replied On May 24, 2011 06:33 AM UTC

Hi Swapna,

Thank you very much for your patience.

The reported issue (i.e.,Category axis labels cannot be set to Auto) has been fixed and the fix has been included in our latest release, Essential Studio Volume 2 2011. The axis label can be set to auto by setting the property of IsAutoMajor as follows;
chart.PrimaryCategoryAxis.IsAutoMajor = true;

The Essential Studio Vol 2 2011 is available for download under the following link. Could you please make use of this and let us know if this helps you?

http://www.syncfusion.com/support/forums/general/99216/Essential-Studio-2011-Volume-2-Final-Release-v920137-available-for-download

Please let us know if you need any further assistance.

Regards,
Pauline Bosco


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

or the page will be automatically redirected to sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;