We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

CommentSelection() do not work

Thread ID:

Created:

Updated:

Platform:

Replies:

94817 Jun 3,2010 12:34 PM UTC Jan 4,2012 07:47 AM UTC WinForms 5
loading
Tags: EditControl
Administrator [Syncfusion]
Asked On June 3, 2010 12:34 PM UTC

Hi
I moved language definitions from code to XML config and CommentSelection() stop comment selected lines.

My XML configuration for comment lexem is :



Also , I checked comment lexem definition from C# and change Type to "Comment", but no effect.

What can be a problem with it?

Thanks
Alex

Karikalan Natarajan [Syncfusion]
Replied On June 4, 2010 09:40 PM UTC

Hi Alex,

Thanks for you using Syncfusion Products. We are happy to assist you.

Here is the sample xml code for comment the line.




...

..



cs



...
...

..



...
//
...




For more information about define config file for language, you can make use the below link.
http://help.syncfusion.com/UG/User%20Interface/Windows%20Forms/Edit/Documents/411creatingacustomlanguageconfigurationfile.htm

Thanks,
Karikalan N

Administrator [Syncfusion]
Replied On July 27, 2010 07:35 AM UTC

Hi Karikalan

I check propoused solution, but is still not work. So currently I back to lexem definition from code to fix the problem


Alex

Lokanath E [Syncfusion]
Replied On August 3, 2010 05:06 AM UTC

Hi Alex,

We regret for the delay in getting back to you,

The code sample suggested in previous update helps to apply configuration to the EditControl.
We have attached a sample for your use at the following link. We hope it might help you to resolve the problem.

http://www.syncfusion.com/uploads/redirect.aspx?&team=support&file=Applyconfig-1842682774.zip

Please let us know if you still face the issue.

Regards,
Lokanath.E

Administrator [Syncfusion]
Replied On January 3, 2012 10:53 AM UTC

Hi Lokanath

Thanks for example

StartComment="//" parameter was missing in my ConfigLanguage definition

Regards
Alex


Rajasekar R [Syncfusion]
Replied On January 4, 2012 07:47 AM UTC

Hi Alex,

Thanks for the update.

We have set the color of the commented line as Blue by using the following line. And this definition is already in our previous update.



And also here I have attached the sample.

http://www.syncfusion.com/downloads/Support/DirectTrac/57527/Applyconfig-1570734627.zip

Please have a look at the above sample and let us know if you have any concerns.

Regards,
Rajasekar R.



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;