We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Error 0x80131417

Thread ID:

Created:

Updated:

Platform:

Replies:

93889 Apr 9,2010 01:08 PM UTC May 3,2010 04:09 AM UTC ASP.NET Web Forms (Classic) 3
loading
Tags: GridGroupingControl
Maurizio Selvaggini
Asked On April 9, 2010 01:08 PM UTC

Hi,
I have a problem in the publication of a website due to an error in the assembly "Syncfusion.grid.windows"
The error is as follows:

[ConfigurationErrorsException: Could not load file or assembly 'Syncfusion.Grid.Windows, Version = 8.103.0.30, Culture = neutral, PublicKeyToken = 3d67ed1f87d44c89' or one of ITS dependencies. Failed to grant minimum permission requests. (Exception from HRESULT: 0x80131417)]

Locally the site is loaded and working properly.
I checked with the utility depends.exe any missing dependencies, without success.
Below shows the list of Syncfusin assemblies configured in web.config:












All assemblies are stored in the bin directory of the website.

Do you have any information to be provided?
Thanks
Maurizio Selvaggini

Bharath M [Syncfusion]
Replied On April 19, 2010 04:54 AM UTC

Hi Maurizio,

We are sorry for delay in response.

We suggest you to remove version and pulickey information from the assembly tag. Please refer the below xml to illustrate this:












Let me know if you have any concerns.

Regards,
Bharath

Maurizio Selvaggini
Replied On April 23, 2010 03:40 AM UTC

Hello Mr Bharath,
I recompiled and published a website testing following the guidelines provided, unfortunately without success.

To reproduce the error on the development PC just change the main web.config (located in c: \ windows \ microsoft.net \ 2.0.50727 \ Config \ web.config) by setting , then recompile a web application that includes the dll Syncfusion.Grid.Windows.
While compiling VS2008 reports the error HRESULT: 0x80131417.

Here I quoted an excerpt from my web.config modified with the trust level = medium














The problem arises because the ISP for security reasons, set the trust level of the web server to Medium. This level of security is usually not modifiable.
I see no solution except to use a dedicated web server where you can change the trust level to Full.

Sincerely
Maurizio Selvaggini

Bharath M [Syncfusion]
Replied On May 3, 2010 04:09 AM UTC

Hi Maurizio,

We are deeply regret for the delay in getting back to you.

Currently we don't have support for "Medium" level trust for Grid. We suggest you to set the Full trust for your website.

Let me know if you have any concerns.

Regards,
Bharath

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;