We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Filter icon displays on column with AllowFilter set to False

Thread ID:

Created:

Updated:

Platform:

Replies:

93492 Mar 16,2010 09:36 PM UTC Oct 11,2010 05:47 PM UTC WPF 3
loading
Tags: GridControl
David Brenchley
Asked On March 16, 2010 09:36 PM UTC

I have a grid where I've set the property ShowFilters="True" at the grid level. At the column level, I've set AllowFilter="False" on a couple of columns I don't want the users to filter by. The problem is that the filter icon still shows up and is usable.

I'm using version 8.104.0.30.

Is this a bug or am I missing a setting.

Clay Burch [Syncfusion]
Replied On March 17, 2010 09:16 AM UTC

There does seem to be an issue with setting AllowFilter = "False" on the visible column in xaml, but you can get it to work if you set it from code as shown in the sample below.

I will forward this issue onto the development team so they can track down why it is not working from xaml.



WpfApplication30_2bad26f8.zip

Scott Jeslis
Replied On August 19, 2010 05:04 PM UTC

This seems to still not be fixed in the 8.3.0.21 release.

Kamalakannan A [Syncfusion]
Replied On October 11, 2010 05:47 PM UTC

Hi Scott,

Sorry for the delay caused.

We have checked with the reported issue and it still remains in volume 3. Could you please create an incident in the Direct Trac to get the fix for the issue.

Please let us know if any queries.

Thanks
Kamal.



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;