We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Display Chinese letters in EditControl

Thread ID:

Created:

Updated:

Platform:

Replies:

78672 Dec 23,2008 05:36 AM Jan 23,2009 02:03 AM Windows Forms 3
loading
Tags: EditControl
G.Mallesham Goud
Asked On December 23, 2008 05:36 AM

Hi,

I am getting repeated characters (Chinese words) when I try to enter data in EditControl.
Ex: 马马 or enter ; you will get ;;

EditControl product version: 4.202.0.37

Thanks
Mallesh




Administrator [Syncfusion]
Replied On January 12, 2009 05:19 AM

Hi Mallesh,

Thank you for your interest in Syncfusion Products,

I have tested the issue in the sample sample that loads the chinese text and I typed text with ';' and '?'. But I am not able to reproduce the mentioned issue. Please refer to the sample below inwhich I have tested the issue:

http://websamples.syncfusion.com/samples/Edit/52326/main.htm

If I am missing anything, could you please let me know in detail so that I could work out in depth and provide you a better solution at the earliest?

Please let me know if any concerns.

Regards,
Fathima


G.Mallesham Goud
Replied On January 21, 2009 04:46 AM

Hi Fathima,

Could you pls change settings of your pc.

0) Install East Asian language on English XP.
1) Open a column for edit.
2) Enter 2 Chinese (TW) words (key stroke [;] and [/].
3) Enter ';' and '/'.
4) Repeat steps 2 & 3 for different text modes (Chinese/English & Half/Full Shape).
It only works properly in English Half Shape,

Please check details in screen shot.

Thanks,
Mallesh.



>Hi Mallesh,

Thank you for your interest in Syncfusion Products,

I have tested the issue in the sample sample that loads the chinese text and I typed text with ';' and '?'. But I am not able to reproduce the mentioned issue. Please refer to the sample below inwhich I have tested the issue:

http://websamples.syncfusion.com/samples/Edit/52326/main.htm

If I am missing anything, could you please let me know in detail so that I could work out in depth and provide you a better solution at the earliest?

Please let me know if any concerns.

Regards,
Fathima





Chinese_6c6fb203.zip

Fathima Shalini P [Syncfusion]
Replied On January 23, 2009 02:03 AM

HI Mallesh,

Thank you for your detailed update.

I am able to reproduce the issue with Full Shape text setup in version 4.2.0.37. We are glad to inform you that the above issue has been fixed with our Esssential Studio verison 5.2.0.25 and further versions. Please refer to the video clip given below:

http://websamples.syncfusion.com/samples/Edit/52326_1/videoreference.zip

I would recommend you to upgrade you to our latest public release Syncfusion Essential Studio 2009 Volume 1 final release which is available for download in the below link:

Download link:

http://www.syncfusion.com/downloads/redirect.aspx?version=7.1.0.21&source=cache&file=syncfusionessentialstudiosetup[244MB]

Unlock key:
If your Essential Studio license is current, you will be able to obtain the key to install this version from your account in DirectTrac. Otherwise, please contact your Syncfusion Sales Representative or e-mail salessupport@syncfusion.com.

In addition to all of your fixes, this release also contains several new features .You can refer the new features in our website from the below provided link.

http://www.syncfusion.com/products/whatsnew/winwhatsnew.aspx

Regards,
Fathima


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;