We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Combobox problem

Thread ID:

Created:

Updated:

Platform:

Replies:

77707 Nov 13,2008 08:15 AM Nov 17,2008 12:28 AM Windows Forms 3
loading
Tags: Tools
Administrator [Syncfusion]
Asked On November 13, 2008 08:15 AM

Hello,

I've got another problem with my combobox. When i want to add one, it goes wrong. I'm getting a strange error, it has something to do with my xpmenu. I allready tried removing & adding references, deleting and adding the xpmenu and trying to add the combobox aing, but still no result.

Someone has an idee how to fix this? (see attachment)

Thanks,
Gunther



combobox-problem_23ed9455.zip

Hemaladha K [Syncfusion]
Replied On November 14, 2008 04:56 AM

Hi Gunther,

Thank you for your interest in Syncfusion Products.

It appears that this issue could be raised due to some reference problems. Could you please do the below given steps?

1. Manually remove all the Syncfusion assemblies (either 6.4.0.15 or previous versions ) from the following locations.


C:\WINDOWS\assembly - GAC
C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5 - reference assemblies.
C:\Program Files\Common Files\Microsoft Shared\MSEnv\PublicAssemblies - Common files
C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies - VS2005 PublicAssemblies
C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PublicAssemblies - VS2008 PublicAssemblies. (if this folder exists)


2) Copy the 6.4.0.15 assemblies from the following location


{Installed Drive}:\Program Files\Syncfusion\Essential Studio\6.4.0.15\precompiledassemblies\6.4.0.15\2.0


and manually place it in the above mentioned GAC and Public Assemblies folders.
Copy and paste does not work in GAC so Drag and drop the assemblies from {Installed Drive}:\Program Files\Syncfusion\Essential Studio\6.4.0.15\precompiledassemblies\6.4.0.15\2.0 to C:\windows\assembly (GAC)

3) Open the VS 2005 IDE and create a project and check for the version 6.402.0.15 in the properties window.

4) If the reference added is not of version 2.0, remove the Syncfusion toolbox and add a Syncfusion toolbox manually using 2.0 assemblies.

5) Try dragging and dropping ComboBoxadv.

Note: Please use the version that you are using currently instead of 6.4.0.15

Please try this and let me know if this helps.

Regards,
Hema


Administrator [Syncfusion]
Replied On November 14, 2008 08:21 AM

Hi Hema,

I've followed your steps below and it worked, i'm not getting an error anymore! Thanks!

But.. i have another problem. I thought this would be fixed by your steps, but that wasn't so. The problem is the passing of values from one form to another where the combobox crashes after a while. The first time of passing some values this is no problem, but after a while the combobox is showing the wrong values and then when i click on it, it crashes.

Do you have any idea of how this is possible?
In attachment, an example of the combobox crash.

Thanks for your help,
Gunther

>Hi Gunther,

Thank you for your interest in Syncfusion Products.

It appears that this issue could be raised due to some reference problems. Could you please do the below given steps?

1. Manually remove all the Syncfusion assemblies (either 6.4.0.15 or previous versions ) from the following locations.


C:\WINDOWS\assembly - GAC
C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5 - reference assemblies.
C:\Program Files\Common Files\Microsoft Shared\MSEnv\PublicAssemblies - Common files
C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies - VS2005 PublicAssemblies
C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PublicAssemblies - VS2008 PublicAssemblies. (if this folder exists)


2) Copy the 6.4.0.15 assemblies from the following location


{Installed Drive}:\Program Files\Syncfusion\Essential Studio\6.4.0.15\precompiledassemblies\6.4.0.15\2.0


and manually place it in the above mentioned GAC and Public Assemblies folders.
Copy and paste does not work in GAC so Drag and drop the assemblies from {Installed Drive}:\Program Files\Syncfusion\Essential Studio\6.4.0.15\precompiledassemblies\6.4.0.15\2.0 to C:\windows\assembly (GAC)

3) Open the VS 2005 IDE and create a project and check for the version 6.402.0.15 in the properties window.

4) If the reference added is not of version 2.0, remove the Syncfusion toolbox and add a Syncfusion toolbox manually using 2.0 assemblies.

5) Try dragging and dropping ComboBoxadv.

Note: Please use the version that you are using currently instead of 6.4.0.15

Please try this and let me know if this helps.

Regards,
Hema





combobox-crash-by-passing-values_184413ec.zip

Hemaladha K [Syncfusion]
Replied On November 17, 2008 12:28 AM

Hi Gunther,

Thank you for your update.

I am afraid that I was not able to reproduce the mentioned issue, please refer to the below simple sample that I have used.

http://websamples.syncfusion.com/samples/Tools.Windows/F77707/main.htm

If I am missing anything, could you please modify the above sample and send us so that I could work out in depth and provde you a better solution at the ealiest?.

Please let me know if any concerns.

Regards,
Hema


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;