We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

SaveBarState/LoadBarState not working properly in MDI application

Thread ID:

Created:

Updated:

Platform:

Replies:

76233 Aug 28,2008 01:44 AM Aug 29,2008 05:28 AM Windows Forms 1
loading
Tags: Tools
Administrator [Syncfusion]
Asked On August 28, 2008 01:44 AM

Hi Experts,

I am facing a problem with LoadBarState/SaveBarState Functions. I am Saving the menus and toolbars state when form is closing and loading them when form is loading. Now i have a form which is an MDI child of this form. When i show this Child form with Form.Show(), the states of tools and menus in main form do not get loaded in the next start. Application works fine if i do not open that MDI child form or if i close it before closing main form(in this case any changes to menus and tools are properly saved and loaded in next start).
I am using 6.2.0.40 version of syncfusion.
Thanks.



Hemaladha K [Syncfusion]
Replied On August 29, 2008 05:28 AM

Hi Paul,

Thank you for your interest in Syncfusion Products.

I am afraid I was not able to reproduce the mentioned issue. Please try reproducing the issue in the below sample and let me know if I missed out anything.
http://websamples.syncfusion.com/samples/Tools.Windows/F76233/main.htm

Regards,
Hema


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;