We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

ButtonAdv bug

Thread ID:

Created:

Updated:

Platform:

Replies:

73365 May 4,2008 11:21 AM UTC Jun 26,2008 11:41 AM UTC WinForms 10
loading
Tags: Tools
Peter Trevor
Asked On May 4, 2008 11:21 AM UTC

Is anyone having problems with ButtonAdv since the last upgrade?

The app I'm working on uses them with the black Office2007 theme. That means that they start out as dark grey with white text. But hover over them and they change to yellow with black text.

However, since the last upgrade when you hover over them (1) they don't change colour, and (2) if you just move from the form to the button only the text goes black, but (3) if you have two buttons in close proximity and move from one to the other then the second appears as an image of the first (with its text) but with the second button's text in black painted over the top. (This looks even worse if I change the first button to use the blue theme instead.)

Actually its not quite that consistant: I have one 'legacy' form with 3 buttons that remains unaffected, one 'legacy' form with 1 button that is affected, plus all new forms are affected.



Ben Bahrenburg
Replied On May 5, 2008 05:07 PM UTC

I'm running into a similar issue. If you mouse over it seems to give me random text. Or if you have it associated with an image index it shows you all of the images


Peter Trevor
Replied On May 5, 2008 09:34 PM UTC

Ah, then if its not just me it must be a real bug. I'll flag it on Direct-Trac.


Administrator [Syncfusion]
Replied On May 8, 2008 12:58 AM UTC

In my case it seems to be linked to how XPMenus are used. If I launch for a menu bar link, it causes all kinds of issues. I've submitted something to Direct - Trac


Fathima Shalini P [Syncfusion]
Replied On May 8, 2008 08:27 AM UTC

Hi Trevor,

Thank you for your interest in Syncfusion Products.

MainframeBarManager's Office2007Theme affects the drawing behaviour of ButtonAdv

We suspect this issue to be a defect. We have reported to our developers regarding this. We will update you in two business days.

Please let me know if any concerns.

Regards,
Fathima


J.Nagarajan [Syncfusion]
Replied On May 23, 2008 03:25 PM UTC

Hi Trevor ,

We have fixed this issue in our latest source. Please open a new Direct trac incident (mention the forum link in the subject line). So that we can provide a patch including this fix.

Thanks,
Nagaraj



Randall Brett
Replied On June 9, 2008 10:41 PM UTC

Any ETA when the fix for this is going to be available?

Thanks.

>Hi Trevor ,

We have fixed this issue in our latest source. Please open a new Direct trac incident (mention the forum link in the subject line). So that we can provide a patch including this fix.

Thanks,
Nagaraj





Fathima Shalini P [Syncfusion]
Replied On June 10, 2008 11:52 AM UTC

Hi Randall,

You can find the patch for the issue MainframeBarManager''s Office2007Theme affects the drawing behaviour of ButtonAdv in the version 6.2.0.40 from the below location and let me know if this helps you.

http://www2.syncfusion.com/Installs/v6.2.0.40/private/syncfusionessentialstudiospsetup_D10232.exe

Regards,
Fathima


Peter Trevor
Replied On June 12, 2008 01:59 PM UTC

Hi Randall, et al

In case you missed it this patch is for 6.2.0.40 and not 6.3.0.6. As such I can report it works but I'm waiting for a fixed 6.3.0.6. It looks like thats been done in the weekly development builds but they are currently reported as unstable. I heard today the next *stable* development build is expected 23 June.



Randall Brett
Replied On June 19, 2008 06:37 PM UTC

I just noticed that the same bug is there in the Calendar control. Is that also fixed in the patch?

Thx

>Hi Randall, et al

In case you missed it this patch is for 6.2.0.40 and not 6.3.0.6. As such I can report it works but I'm waiting for a fixed 6.3.0.6. It looks like thats been done in the weekly development builds but they are currently reported as unstable. I heard today the next *stable* development build is expected 23 June.





Fathima Shalini P [Syncfusion]
Replied On June 26, 2008 11:41 AM UTC

Hi Randall,

Thank you for your update.

I tested the issue with DateTimePickerAdv. But the issue is not reproduced. Please refer the below sample for more details:

http://websamples.syncfusion.com/samples/Tools.windows/F73365/main.htm

Could you please let me know the exact scenario in which the issue is reproduced, so that I could trace out the cause of the issue and provide you a better solution?

Please let me know if any concerns.

Regards,
Fathima


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;