We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

TabControlAdv, Textbox and Anchor

Thread ID:

Created:

Updated:

Platform:

Replies:

51548 Nov 8,2006 08:46 AM UTC Nov 11,2006 12:14 AM UTC WinForms 6
loading
Tags: Tools
Administrator [Syncfusion]
Asked On November 8, 2006 08:46 AM UTC

Hi.

When I add a TextBox in a TabcontrolAdv and set the anchor of the textbox to “Top, Left, Right”, the textbox size gets reset to a value same as the TabControlAdv width.
You can see this if you close and open the form again.

What is the problem with this? Is this a bug?
Any help?

I use VS2003, Net1.1, syncfusion 4.2.0.37

Thanks
Stelios Halkiotis

Purusothaman R [Syncfusion]
Replied On November 8, 2006 06:18 PM UTC

Hi Stelios,

I am unable to reproduce the issue in our sample.

There was a Bug (Bug # 2290) in v4.2.0.37, related to resizing of Container controls inside TabPage. And it has been resolved in the versions released after v4.2.0.37.

Are you using any Container controls in the Tabpage and placing the TextBox inside it? Kinldy send us an sample, so that it will be helpful for us to investigate this issue further.

Thanks for using Syncfusion Products.

Regards,
Purusothaman.R

Administrator [Syncfusion]
Replied On November 9, 2006 07:49 AM UTC

Hi.
I am attaching a sample.

Regards

sample112.zip

Administrator [Syncfusion]
Replied On November 9, 2006 07:54 AM UTC

Forgot to mention that at runtime the controls do not appear resized but only at design time. this cause a lot of problems in designing the form


Stelios.

Purusothaman R [Syncfusion]
Replied On November 9, 2006 06:38 PM UTC

Hi Stelios,

We worked with your sample using v.4.2.0.37 and could not reproduce any issue in it. The Controls are not resized in Designer. It looks same as it looks in the Run time.

Can you reproduce the issue in all sample or just in a particular sample?

Thanks,
Purusothaman.R

Administrator [Syncfusion]
Replied On November 10, 2006 07:59 AM UTC

Hi Purusothaman.

Thanks for your reply.
It is strange because this happens everytime.
It is not a problem of a specific project.
have a look at the attached file, which shows this strange behavior.

Best regards
stelios.


Sample211.zip

Purusothaman R [Syncfusion]
Replied On November 11, 2006 12:14 AM UTC

Hi,

We regret for the inconvenience caused.

I tested few samples in both C# and VB.NET. But for some reasons, I am unable to reproduce this issue.

I am attaching a video of my sample.

AnchorVideo.zip

Thanks for using Syncfusion Products.

Thanks,
Purusothaman.R

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;