We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Node Selection Problems

Thread ID:

Created:

Updated:

Platform:

Replies:

50027 Oct 3,2006 04:59 PM Aug 8,2007 09:04 PM ASP.NET Web Forms (Classic) 17
loading
Tags: DiagramWebControl
David A. Gonzales
Asked On October 3, 2006 04:59 PM

If I try to click a symbol on a diagrammer I get a "Error: __sfDiagramWebControl1 is undefined". I have the EnableNodeSelection and EnableDragDrop set to true. The diagrammer is dynamically loaded from a user created palette file (the symbols and links come up just fine).

thanks.
David.

J.Nagarajan [Syncfusion]
Replied On October 4, 2006 01:58 PM

Hi David ,

We regret for the inconvenience caused. I have tested this issue in v.4.3.0.30.I am afraid, I was not able to reproduce this issue. I have tested this issue in our QuirkyText sample.

Could you please check the sample and let me know whether you are able to reproduce the issue in this sample?. It would be helpful if you provide a sample or modify theQuirkyText sample to reproduce this issue. It will help us to resolve it as early as possible.

Thanks for using Essential Diagram.

Regards,
J.Nagaraj

David A. Gonzales
Replied On October 5, 2006 01:35 AM

Thanks. I will check the sample and let you know.

David.

David A. Gonzales
Replied On October 5, 2006 03:45 PM

If I place the diagram control on a normal web form (ie, not in my Master Page content) it works correctly. However, once I place the control in a content panel in a Master Page scenario it does not work. Do I need to do something different when using Master Pages? I would hate to think that I need to re-create all my pages without Master Pages just to get this to work. That is why I am getting other problems with some of the other Syncfusion controls! It is all starting to make sence.

Thanks.

David

ps - I will see if I can find anything in the knowledge base on this.

J.Nagarajan [Syncfusion]
Replied On October 9, 2006 12:19 PM

Hi David,

We regret for the inconvenience caused. I have tested this issue in v.4.3.0.37. I am afraid, I was not able to reproduce this issue. I have attached my test sample.

MasterPage.zip

Could you please check the sample and let me know whether you are able to reproduce the issue in this sample?. It would be helpful if you provide a sample or modify the sample attached to reproduce this issue.It will help us to resolve it as early as possible.

Thanks for using Essential Diagram.

Regards,
J.Nagaraj

J.Nagarajan [Syncfusion]
Replied On October 9, 2006 12:19 PM

Hi David,

We regret for the inconvenience caused. I have tested this issue in v.4.3.0.37. I am afraid, I was not able to reproduce this issue. I have attached my test sample.

MasterPage.zip

Could you please check the sample and let me know whether you are able to reproduce the issue in this sample?. It would be helpful if you provide a sample or modify the sample attached to reproduce this issue.It will help us to resolve it as early as possible.

Thanks for using Essential Diagram.

Regards,
J.Nagaraj

David A. Gonzales
Replied On October 9, 2006 03:32 PM

I tried the sample that you submitted (without any modification) and it still comes up with the __sfDiagramWebControl1 undefined when I try to click the symbol. I have tested it in Firefox and IE6. I will try the sample at home in my other development environment. Again, if I move the control out of a master page environment it works just fine (ie, remove MasterPage reference, remove ContentPlaceHolder and add
Your Code


Thanks.
David.

David A. Gonzales
Replied On October 9, 2006 03:46 PM

Sorry about the multiple posts. I was getting a web error off your web site and was resubmitting. Sorry about that.

David.

J.Nagarajan [Syncfusion]
Replied On October 12, 2006 08:14 PM

Hi David,

Sorry for the delay in getting back to you. For some reasons I was not able to reproduce this issue.I have tried to reproduce this issue in the following environment: Windows XP with SP2, .NET 2.0 Framework and Essential Studio v.4.3.0.30. Could you please let me know the OS version and System configuration that you are using currently? It will help us to resolve this issue accurately.

Thanks for your patience.

Regards,
Nagaraj

David A. Gonzales
Replied On October 17, 2006 12:06 PM

I am using the same environment as you (except I am running Windows 2000). I have included the output from the run with your MasterPage sample. The line number is around 49. Says that the function is undefined. The line in question is:

__sfDiagramWebControl1.callback(arg);

The question I have is if it's in a MasterPage content panel should not the call be something like:

__sfctl00_ContentPlaceHolder1_DiagramWebControl1.callback(arg);


I ran into this problem before when using a callback control and a MasterPage (see Tools Forum under Callback Panel with Master Pages).

Again, the sample you sent crashes at that line I mentioned but works find if I take it out of the master page environment.

Thanks.
David.

crash2.zip

J.Nagarajan [Syncfusion]
Replied On October 30, 2006 03:52 PM

Hi David ,

We regret for the inconvenience caused. I have tested this issue and it seems to be a bug in DiagramWebControl. I have logged a bug report # 2937 in this regard. You can track the progress of this issue at this link below :

Defect #2937 - Node Selection problem when the diagram in master Page.

Thanks for bringing this issue to our attention. We will fix this issue at the earliest and keep you informed.

Thank you,
J.Nagaraj.

Salman Dhunna
Replied On May 22, 2007 07:14 AM

Hi Nagarajan,

I tried using the Diagram control on aspx page, works fine. But if I wrap the diagram control inside an ascx page, and browse to the page containing this ascx , i get an error __sfDiagramWebControl1 is undefined.

Please advice.

Thanks,
Salman

Ramya R [Syncfusion]
Replied On May 25, 2007 10:00 AM

Hi Salman,

The issue that you have mentioned here seems to be a bug with our DiagramWebControl.Thank you for bringing this issue to our attention.

We have created incident of ID #34370 in your Direct Trac account and have updated it with the details regarding the bug.

Kindly followup with your queries regarding this issue in this incident.

Thanks & Regards,
Ramya.

Rodrigo Giosa
Replied On August 7, 2007 02:51 PM

Sorry, but the problem still happens. The attachments solutions does not have a MasterPage.

Melba Winshia [Syncfusion]
Replied On August 8, 2007 09:48 AM

Hi Rodrigo,

Thank you for the update.

Please follow this issue in incident #34370 so that we can provide more details regarding this issue.

Kindly let me know if you have any other questions.

Thanks,
Melba

Rodrigo Giosa
Replied On August 8, 2007 09:53 AM

Hi Melba!

But the issue was not resolved. The solution that they put in the "attachments solutions" does not have a Master Page - so not fires an error.

Sorry for my poor english! ;)

Tks!

Rodrigo Giosa
Replied On August 8, 2007 02:18 PM

My message above!

Sarath Kumar G [Syncfusion]
Replied On August 8, 2007 09:04 PM


Hi David,

Thank you for your continued interest in Syncfusion products.

This issue is been fixed internally. The latest version of Essential Studio - v5.1.1.40 is available for download from the below location,

http://www2.syncfusion.com/installs/v5.1.1.40/syncfusionessentialstudiosetup.exe

Unlock key:

If you hold a Syncfusion license with a valid subscription, you can obtain your key for this version by visiting the "Download the latest versions" section within Direct-Trac and clicking on the appropriate key icon. If you're currently evaluating our products or considering renewing an expired subscription, please write to salessupport@syncfusion.com to request a key.

Please let me know if you need further help.

Regards,
Sarath

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;