We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Typing oriental language(Korean or Japanese) appears to "???"

Thread ID:

Created:

Updated:

Platform:

Replies:

47341 Aug 2,2006 08:48 PM Aug 6,2006 10:24 AM Windows Forms 6
loading
Tags: EditControl
joys
Asked On August 2, 2006 08:48 PM


I use the Syncfusion Essential studio 4.2.0.37.

There are 2 problems.

Problem 1. In default setting, typing any characters in Korean or Japanese display ''?''.


[Action 1] After any unicode file loaded (by editControl1.LoadFile(..); ), typing Korean or Japanese characters displayed well.

Problem 2. After [Action 1], when type Korean or Japanese characters, it displayed to the small rectangle in top-left of screen, not in a edit control. (maybe a kind of a buffer)

Problem 3. --> most series!
In unicode input mode, some characters are duplicated. (You can see this error in the edit sample "edit samples/Text Formatting/UnicodeDemo".

Reproduction sequence is follow:
1. Open the sample browser.
2. Select the UnicodeDemo sample.
3. Process "Run Sample" command.
4. You can see a window which is displayed Hebrew text.
5. Type Korean or Japanese characters.

then when you type or , the buffered characters would be duplicated.

Please check those errors and let me know about when I can receive a fixed version..

Thanks in advance.
Joys




Administrator [Syncfusion]
Replied On August 3, 2006 06:06 AM

Hi Joys,

Thanks for bringing this issue to our attention. I do see this problem here and have notified the development team in this regard. We have logged a bug report Defect # 2499 on this, and will try our very best to address the same at the earliest. You could track the progress of this bug fix at this link below :

Defect #2499 - EditControl duplicates Japanese or Korean characters when Enter key is used.


Thanks for your patience.

Regards,
Manohari.R

joys
Replied On August 3, 2006 08:06 AM


Hi, Manohari.

Thank you for your action about problem3.

Please check problem1 and problem2 also.

Problem1 is easily reproducible.
1. Run any sample related not to unicode.
2. Type Korean or Japanses characters in default setting.
3. then you might see ?

Please let me know, how can I edit Korean (or Japanese) in default setting.

Problem2 also troubles me.
Because it is an editor, our customers want to see the characters just typed in editor window.

Thanks in advance,
Joys.

Administrator [Syncfusion]
Replied On August 3, 2006 10:36 AM

Hi Joys,

Our apologies for the delayed response. We are looking in to these issues and will get back to you shortly.

Thanks for your patience.

Regards,
Manohari.R

Administrator [Syncfusion]
Replied On August 4, 2006 05:50 AM

Hi Joys,

It is possible to edit Korean and Japanese characters by setting text encoding to Unicode. I have attached a
sample
that illustrates this.

Please let me know if this meets your requirements.

I have tested for problem2 and was able to see the small rectangular window. I have notified the development team in this regard and updated Defect#2499 with this information. You could track the progress of this bug fix at this link below :

Defect #2499 - Issues with EditControl when Japanese or Korean characters are used.


We will try our very best to address the same at the earliest.

Thanks for your patience.

Regards,
Manohari.R

joys
Replied On August 6, 2006 10:23 AM


Hi Manohari.

Thank you for four sample helping problem1.
It helped me exactly for problem1.

And I also thank you for your actions solving remaining problems.

Sincerely,
Joys

joys
Replied On August 6, 2006 10:24 AM

sorry for typing miss.
four -> your

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;