We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Datagrid header in Chinese

Thread ID:

Created:

Updated:

Platform:

Replies:

40024 Jan 23,2006 09:07 PM Feb 22,2006 02:25 PM Windows Forms 13
loading
Tags: GridControl
Steven Tsai
Asked On January 23, 2006 09:07 PM

Hi , I am encountering problem with Datagrid Header the scenarios are: 1. add a datagrid, bind with data 2. add resx for chinese 3. add chinese header for data grid column header the column header mess up in both english and chinese can any one help in this, I have not yet went through the forum. is there any solution or problem other have encountered?

Administrator [Syncfusion]
Replied On January 24, 2006 07:52 AM

Hi Medicomm, There are related articles in the KnowledgeBase section and here is the one you are looking for < a rel='nofollow' href = "http://www.syncfusion.com/support/kb/tools/Default.aspx?ToDo=view&questId=293" >How do I localize all the text associated with Syncfusion controls in my application? Refer this if you need to handle Localization using Resource file Thanks Haneef

Steven Tsai
Replied On January 24, 2006 08:47 PM

hi thanks alot, I know how to do that, but I am encountering bugs the datagrid column sequence mess up in both english and chinese mode, after I add chinese character in datagrid column header , there are more than 2 tabs in my datagrid. I am currently using syncfusion 3.2.0.1 can you please help for this

stanleyj [Syncfusion]
Replied On January 25, 2006 03:52 AM

Hi Medicomm, I am not sure, what you expect the grid to do. The code below will change the first column header text. private void Model_QueryCellInfo(object sender, GridQueryCellInfoEventArgs e) { if(e.ColIndex == 1 && e.RowIndex == 0) e.Style.Text = "Local"; } If the above code does not help, please upload a sample, so that we may suggest some solutions. Best regards, Stanley

Steven Tsai
Replied On February 2, 2006 02:42 AM

Hi , sorry for the delay , just came back from chinese new year holiday. please check this, in this project 1. I am using gridgrouping control inside the tab, 2. and I binded some data from SQL server, 3. I switch the language of this form into chinese traditional 4. I add chinese header text for each tab and each column in tab4 under the table descriptor 5. when I switch back to default language , the column header screwed up. I didn''t edit anything in english mode

BugofChineseColumnHeader.zip

stanleyj [Syncfusion]
Replied On February 3, 2006 04:30 AM

Hi Medicomm, Thanks for the sample, but I do not see any issue. what exactly am I to do in order to see the problem? When you say ''when I switch back to default language'' are you switching the languages in the Region and Language setting options? Regards, Stanley

Steven Tsai
Replied On February 5, 2006 08:47 PM

hi , thanks for your reply when I say ,switch into default, means on the from the property -> language of the form1 I need to add chinese in chinese mode, once I have done, I need to switch it back to default and let the non-chinese clients have the english please check the pic001.jpg the chinese column in chinese mode, should not display at the default language mode(tabpage4), that is the problem... because I didn''t input any chinese in default mode.

pic001.zip

stanleyj [Syncfusion]
Replied On February 7, 2006 06:36 AM

Hi Medicomm, The first column (AccessionNum1) of the grid in TabPage4, looks to work in the way needed, am I right? If so please check the Form1.resx file that has Chinese text for the other column header text, I think they are supposed to be in Form1.zh-CHT.resx file. Best regards, Stanley

Steven Tsai
Replied On February 10, 2006 07:47 PM

that''s the bug I want to report, because I added thise chinese character in the CHT.resx not

Steven Tsai
Replied On February 10, 2006 07:47 PM

that''s the bug I want to report, because I added thise chinese character in the CHT.resx not

Steven Tsai
Replied On February 10, 2006 07:49 PM

that''''s the bug I want to report, because I added thise chinese character in the CHT.resx not in default mode, but the system mess up the chinese character

Administrator [Syncfusion]
Replied On February 12, 2006 04:30 PM

Hi Medicomm, try to specify the CultureInfo for the column where you want a different culture than the default culture info. In your case you should specify the culture in the Column.Appearance.ColumnHeaderCell.CultureInfo. You need to do this for every column where you want a culture that differs from the default culture. See this screenshot. It shows the property grid where you need to set the culture. screen2.zip If the culture is not specified for the column than it will use the default culture that is specified for the form. Stefan

Administrator [Syncfusion]
Replied On February 21, 2006 02:19 AM

Thanks Staphen, but doing this, the data grid will show chinese in English mode.

Administrator [Syncfusion]
Replied On February 22, 2006 02:25 PM

I played a bit with your sample. See attachement here: Forum_40024(2).zip I made one column header be english when the chinese language is selected and also one column header be chinese when default language is selected. See the screenshots here: f40024.zip When you load the solution you can switch languages. You should check the second column in tabpage4. Let me know if I misunderstood you and this is not what you are looking for. Stefan

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;