We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Gradient Problem

Thread ID:

Created:

Updated:

Platform:

Replies:

22962 Dec 30,2004 02:12 PM UTC Mar 8,2005 06:05 AM UTC WinForms 5
loading
Tags: Tools
Michel T Dallaire
Asked On December 30, 2004 02:12 PM UTC

Hi, Eveytime I use something with gradient capability I get this problem. I put 2 colors. In the designer, is ok. but when I run the program, it reverses the order of the color. Furthermore, when I copy a component with gradient settings, it toggles the color. There is no way I can get it to work perfectly. It seems also that when i rechange the colors, it affect the other controls. It''s very strange. It does that in every projet. I even stated a fresh new one with gradient label and panel, only, and it''s the same problem. I had not that problem in Version 2. Regards, Michel

Administrator [Syncfusion]
Replied On January 3, 2005 10:18 PM UTC

Hi Michel, I am afraid, this information is not sufficient to identify the problem here. A test sample showing the same would be of great help. Also, please provide us with the following information. 1. Does your machine have only v3.0.1.0 installed on it ? 2. Have you set the CopyLocal property to false for the Syncfusion references in the project ? If not, please do so. 3. What is the OS and version of VS.NET (2002 or 2003) used ? Thanks for your cooperation. Regards, Guru Patwal Syncfusion, Inc.

TJ
Replied On January 5, 2005 01:45 PM UTC

I''ve just noticed this too. When you use a gradient background color in a Gradient Panel, the designer accidentally reverses the two colors. So you see one gradient in the Designer, and the opposite gradient in the compiled code. You can easily duplicate this in a brand new project with just the one gradient panel for testing. I''ve worked around it by resetting the gradient in code, after InitializeComponent. Cheers, Tom

Administrator [Syncfusion]
Replied On January 5, 2005 08:26 PM UTC

Hi Michel, There was a bug in the BrushInfo class which was causing the gradient colors to switch. The problem has been fixed internally and it will be available in the next patch release. Sorry for the inconvenience.Thanks. Stephen. >Hi, > >Eveytime I use something with gradient capability I get this problem. > >I put 2 colors. In the designer, is ok. but when I run the program, it reverses the order of the color. > >Furthermore, when I copy a component with gradient settings, it toggles the color. There is no way I can get it to work perfectly. It seems also that when i rechange the colors, it affect the other controls. > >It''s very strange. It does that in every projet. I even stated a fresh new one with gradient label and panel, only, and it''s the same problem. > >I had not that problem in Version 2. > >Regards, >Michel >

Jurgen Beck
Replied On March 7, 2005 07:18 PM UTC

Hi Stephen, Any ETA on when we can expect the service pack? Still having issues with the flipping gradient colors here too. Thanks, Jurge

Administrator [Syncfusion]
Replied On March 8, 2005 06:05 AM UTC

Hi Jurgen, I have created a Direct-Trac incident# 17153 in this regard. Please refer to my response there and let me know if you need any other information. We appreciate your cooperation. Regards, Guru Patwal Syncfusion, Inc.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;