We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
close icon

checkbox select all bug not selection on first click

Hello,

I have a datagrid component with a gridcolumn of type checkbox.

When you click the checkbox in the header, it should select all checkboxes.

On first click, it only selects the last element in the table.

After deselect and select again, then the correct behavior occurs. 

Im on 

the nuget packages I tested on

20.4.0.51 - broken

20.4.0.38 - working



I have attached a video and a project sample


Attachment: BlazorWASMApp_66b92985.zip

7 Replies

CE Coda Error Analysis February 24, 2023 08:28 PM UTC

You should open a ticket and report it as a bug.   I did that recently for the Grid, and the response was immediate, and they had a fix out within a couple of weeks.



MS Monisha Saravanan Syncfusion Team February 27, 2023 02:01 PM UTC

Hi Pavel,


Greetings from Syncfusion.


We have considered it as an breaking issue and logged an task  “SelectAllCheckBox does not work properly when header checkbox is clicked” for the same. Thank you for taking time to report this issue and helping us to improve our product. At Syncfusion, we are committed to fix all validated defects (subject to technological feasibility and Product Development Life Cycle). You can now track the current status of your request, review the proposed resolution timeline, and contact us for any further inquiries through this link and we will resolve this issue in our upcoming patch release which is going to be held on March 8th, 2023.


https://www.syncfusion.com/feedback/41574/selectallcheckbox-does-not-work-properly-when-header-checkbox-is-clicked


Until then we appreciate your patience.


Regards,

Monisha




PA Pavel February 27, 2023 03:59 PM UTC

Hello, when I visit the link you provided, it says page not found. thank you



MS Monisha Saravanan Syncfusion Team February 28, 2023 04:10 AM UTC

Hi Pavel,


Sorry for the inconvenience. We have provided access to your mail. Kindly check the feedback link now and get back to us if you still face any issues.



PA Pavel March 7, 2023 04:26 PM UTC

Looks like it was fixed for regular table but I identified the same issue when initial group setting are applied to the table.

<GridGroupSettings Columns="@_initialGrouping">GridGroupSettings>



Also when you have a few rows selected, the deselect all button does not work properly. When you click de-select all, one row is still selected.



MS Monisha Saravanan Syncfusion Team March 8, 2023 01:03 PM UTC


Hi Pavel,


Sorry for the inconvenience caused.


Query: “Looks like it was fixed for regular table but I identified the same issue when initial group setting are applied to the table.”


Yes we have fixed the issue for the normal Grid and we have consider your reported scenarios and we are currently working on fixing those issues and the fix for the issue will be included in our upcoming patch release which is expected to be rolled out on 15th March 2023.


Until then we appreciate your patience.


Regards,

Monisha



MS Monisha Saravanan Syncfusion Team March 16, 2023 04:19 AM UTC

Hi Pavel,


We are glad to announce that, we have included the fix for the issue “SelectAllCheckBox does not work properly when header checkbox is clicked” in our release (20.4.0.54).  So please upgrade to our latest version of Syncfusion NuGet package to resolve the reported issue. Please find the Nuget package for latest fixes and features from below.


Nuget : https://www.nuget.org/packages/Syncfusion.Blazor.Grid


We thank you for your support and appreciate your patience in waiting for this release. Please get in touch with us if you would require any further assistance. 


Regards,

Monisha



Loader.
Live Chat Icon For mobile
Up arrow icon