We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: June 24, 2019).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Print landscape report silently

Thread ID:

Created:

Updated:

Platform:

Replies:

145480 Jun 24,2019 07:43 PM UTC Jun 26,2019 10:10 AM UTC WPF 3
loading
Tags: ReportViewer
Christian Franken
Asked On June 24, 2019 07:43 PM UTC

Hello,

I print my rdlc reports with the code from the kb: kb9658

Now he always prints in portrait mode. See attached files.


What do I have to change to print in landscape mode?

best regards
Chris

Attachment: failure_cce56139.zip

Vinoth Srinivasan [Syncfusion]
Replied On June 25, 2019 08:59 AM UTC

Hi Chris, 
 
Thanks for your interest in Syncfusion Components. 
 
If your requirement is to print the report in Landscape mode, then you have to change the report orientation as “Landscape” from Report Properties. Please find the below steps for changing report orientation. 
 
1.      Right click on the “Report” area in RDLC report and select Report Properties. 
 
 
 
2.      Now change the Orientation of the report as Landscape to print the report in “Landscape” mode. 
 
 
If you still face any issue, then please share your RDLC report with us and it will be helpful for us to provide the solution at the earliest. 
 
Regards, 
Vinoth S. 


Christian Franken
Replied On June 25, 2019 08:27 PM UTC

Hello,
thanks for the first answer :)

Unfortunately, I had already set the report to landscape format.

I have attached a video in which the process (checking report and printing) can be viewed.

In addition, I saved the generated pdf.
(reportWriter.Save(stream, WriterFormat.PDF);
//save pdf to fs (test purpose) (pdf attached)
reportWriter.Save("test.pdf", WriterFormat.PDF);)


Regards,
Chris

Attachment: error_9b164eb0.zip

Vinoth Srinivasan [Syncfusion]
Replied On June 26, 2019 10:10 AM UTC

Hi Chris, 

Thanks for you update. 

We have further validated the reported problem at our end and the PDF exported with Landscape orientation properly. While printing the report it uses the printer installed in your machine, so you have to set the paper orientation as Landscape in printer settings to print the report in Landscape mode. 

Regards, 
Vinoth S. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

Live Chat Icon For mobile
Live Chat Icon