We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Set dataSource

Thread ID:

Created:

Updated:

Platform:

Replies:

132365 Aug 28,2017 04:25 PM Aug 31,2017 06:46 AM ASP.NET MVC 3
loading
Tags: Grid
Bernard Jurlina
Asked On August 28, 2017 04:25 PM

I have a grid like this:


and when I set it's datasource from ajax like this:
$.ajax({
            cache: false,
            url: src,
            data: { "odDatuma": odDatuma, "doDatuma": doDatuma, "SetID": setID },
            type: "get",
        }).done(function (data) {
            obj.dataSource(data);
        }).fail(function(xhr, status, error) {
            var err = eval("(" + xhr.responseText + ")");
            alert(err.Message);
        });

I get filter icon on first two unbound columns like this:


Any ideas how to avoid this?
Thanks!


Prasanna Kumar Viswanathan [Syncfusion]
Replied On August 29, 2017 09:08 AM

Hi Bernard, 

Thanks for contacting Syncfusion support. 

We created a sample in Grid with two unbound columns(columnTemplate, commandColumn) and when we set dataSource through ajaxPost we did not get the filter icons in the unbound columns. So, we unable to reproduce the mentioned issue in our sample.  

Find the screenshots: 

Before set dataSource through ajaxPost. 

 

After set dataSource:  

 

To find out the root cause, we need the following details. 

1. Code example of a Grid.  

2. Have you used columnTemplate feature to bind the unbound column in Grid?  

3. Essential Studio Version details.  

4. If possible, replicate the issue in the attached sample.  


Regards, 
Prasanna Kumar N.S.V 
 


Bernard Jurlina
Replied On August 30, 2017 03:43 PM

Hi Kumar,

and thanks for the tip.
I was using Format option for the unbound columns, and when I changed that to columnTemplate, then it works like a charm.

Regards,
Bernard.



Prasanna Kumar Viswanathan [Syncfusion]
Replied On August 31, 2017 06:46 AM

Hi Bernard, 

We are happy to hear that the provided solution has been working fine at your end. 

Please let us know if you need any further assistance. 

Regards, 
Prasanna Kumar N.S.V 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;