We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Expression error

Thread ID:

Created:

Updated:

Platform:

Replies:

128094 Jan 2,2017 06:06 AM Jan 4,2017 07:32 AM ASP.NET MVC 3
loading
Tags: ReportViewer
Anis
Asked On January 2, 2017 06:06 AM

Hi,
I create a repoort using "Syncfusion Report Designer", I  add % column and I use this expression on it:
"=ReportItems!TextBox21.Value/ReportItems!TextBox22.Value"
I get an error on Report Designer and on the browser when I run my project, but when I open the report with "SQL Report Builder, everything works fine (take a look at the screenshot below).
What is the problem?

Attachment: Screenshot_6456c914.rar

Yuvaraj Devarajan [Syncfusion]
Replied On January 3, 2017 04:20 AM

Hi Anis, 
 
Thanks for contacting Syncfusion support. 
 
We were unable to reproduce the mentioned the same null exception issue at our end. But, we have tested the shared reportitem expression and it’s rendered the same values in all the row cells (this is the know error) in Tablix report items as shown in below screenshot. So can you please share the issue reproducible RDL file without confidential information to validate the mentioned null exception issue at our end.  

ReportViewer O/P: 
 
 
For your reference, we have prepared a sample and it can be downloaded from, 

Regards,
 
Yuvaraj D 


Anis
Replied On January 3, 2017 07:22 AM

Hi,
I reproduce the issue in the sample below (+RDL file).
About your RDL file, I get the same error (render the same values in all the row cells) but instead it works well in SQL Report Builder.
Another problem about the percentages, I have diagrams (Pie) showing the percentage of each part in SQL Report Builder, but in the browser (ReportViewer), it just show me the total number without percentage. How to fix this too?

Regards,
Anis


Attachment: Report_4cce0efe.rar

Yuvaraj Devarajan [Syncfusion]
Replied On January 4, 2017 07:32 AM

Hi Anis, 

Currently, we don’t have support for using aggregate function for reportitems expression in ReportViewer and we have an issue while providing data label format in chart report item at our end. We have logged a feature and defect report on this respectively. So a support incident to track the status of this feature and issue has been created under your account. Please log on to our support website to check for further updates.
https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents 

Regards, 
Yuvaraj D. 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;