We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Force default “Landscape” in Page Setup… (Report Viewer)

Thread ID:

Created:

Updated:

Platform:

Replies:

124703 Jun 23,2016 10:53 AM Jul 20,2016 01:45 AM LightSwitch HTML 8
loading
Tags: ReportViewer
Tom
Asked On June 23, 2016 10:53 AM

Hello,

I was wondering whether it is possible to force “Landscape” setting under Page Setup?

For some reason the control doesn’t honour settings embedded in RDL report. Report has been setup to Landscape, but the control always shows “Portrait” as default. Is there any way to change that in the code, so the report always opens with "Landscape" setting as default?

Thank you very much in advance,

Kind regards,

Tom


Tom
Replied On June 23, 2016 12:01 PM

Hello,

I was wondering whether it is possible to force “Landscape” setting under Page Setup?

For some reason the control doesn’t honour settings embedded in RDL report. Report has been setup to Landscape, but the control always shows “Portrait” as default. Is there any way to change that in the code, so the report always opens with "Landscape" setting as default?

Thank you very much in advance,

Kind regards,

Tom


Sorry, I have just realised that Page Setup has nothing to do with printing. My problem is that when I use Print button my reports gets always printed in Portrait. I assumed that it must have something to do with Page Setup within the control, but it proved not to be the case.
When I export the report to PDF and then print, it prints perfectly fine in landscape. However, when I use Print function, it always prints in portrait unless I change settings in properties of printer driver before printing the report.
Any suggestions would be greatly appreciated.

Many thanks,

Kind regards,
Tom

Yuvaraj Devarajan [Syncfusion]
Replied On June 24, 2016 06:23 AM

Hi Tomasz, 
 
Thanks for contacting Syncfusion support. 
 
We are unable to replicate the mentioned the issue while changing the orientation with current source. We have prepared a working sample & video which can be downloaded from the below location  
 
Please share the referred ej.web.all.min.js script with replication procedure details and confirm your Essential studio product version to validate the mentioned issue at our end.   
 
Regards, 
Yuvaraj D. 


Tom
Replied On June 24, 2016 06:55 AM

Hi Tomasz, 
 
Thanks for contacting Syncfusion support. 
 
We are unable to replicate the mentioned the issue while changing the orientation with current source. We have prepared a working sample & video which can be downloaded from the below location  
 
Please share the referred ej.web.all.min.js script with replication procedure details and confirm your Essential studio product version to validate the mentioned issue at our end.   
 
Regards, 
Yuvaraj D. 


Hello Yuvaraj,

Thank you very much for quick reply. I have checked your sample and it behaves exactly the same way as mine.
On the demo video you sent print to XPS Document Viewer instead of an actual printer. I tested that earlier with xps and pdf formats and once exported to pdf or xps everything works fine. However, when I try to send the print to an actual printer, it always prints in portrait. Would you be so kind and try to print directly on the printer instead of sending to XPO Document Viewer? I wonder whether it behaves the same way at your end.
I've just tested it on two different printers and it always prints in portrait. However, as I said earlier, when I export to xps or pdf first, it always prints fine.

Thank you very much in advance,
Regards,
Tom

Yuvaraj Devarajan [Syncfusion]
Replied On June 27, 2016 06:40 AM

Hi Tomasz, 
 
We have tested the reported issue by printing report from our ReportViewer control and the mentioned issue is not reproduced at our end. We have printed the report paper size option as “Letter” with landscape orientation and reports are printed in landscape format as expected. For your reference, we have taken the screenshot of the printed paper and it can be downloaded from the below location,   
  
Please confirm the paper size option used to print the report to validate the mentioned issue at our end.   
    
Regards,   
Yuvaraj D.     


Tom
Replied On July 13, 2016 01:16 PM

Hi Tomasz, 
 
We have tested the reported issue by printing report from our ReportViewer control and the mentioned issue is not reproduced at our end. We have printed the report paper size option as “Letter” with landscape orientation and reports are printed in landscape format as expected. For your reference, we have taken the screenshot of the printed paper and it can be downloaded from the below location,   
  
Please confirm the paper size option used to print the report to validate the mentioned issue at our end.   
    
Regards,   
Yuvaraj D.     


Hi Yuvaraj,

My apologies for delay in reply. I was away for a while. 

I've just had a look at the screen prints attached by yourself and they look like they have been printed in portrait on A4 paper and not landscape. That is precisely what I'm getting.
When I export to PDF first, everything works fine (prints in landscape). 

Please see scans attached. Please note that my report was built in landscape under SSRS and prints fine from there.
"Portrait.jpg" is what I get when I try to print directly from the report viewer by using print button (it prints like that regardless of what I change the settings to in Page Setup).
"Landscape.jpg" is what I get when I export to PDF first and then print. This is what I'm trying to achieve.

Thanks!
Kind regards,
Tom

Attachment: Images_57fb414e.zip

Selvakumar Singadurai [Syncfusion]
Replied On July 14, 2016 06:32 AM

Hi Tomasz,   
Sorry for the inconvenience caused.    
We are unable to replicate the mentioned issue with the given information. So please share the reproducible video and confirm your product version to validate the mentioned scenario at our end.    
Regards,   
Selvakumar S.   


Tom
Replied On July 19, 2016 07:37 AM

Hi Tomasz,   
Sorry for the inconvenience caused.    
We are unable to replicate the mentioned issue with the given information. So please share the reproducible video and confirm your product version to validate the mentioned scenario at our end.    
Regards,   
Selvakumar S.   


Hi Selvakumar,

Thanks for your reply. I must say that I'm confused now. You said that you are unable to replicate this issue despite the fact that your sample video attached to the post from 24/06 was showing precisely the same problem. On that video you changed settings to landscape and clicked on Print Layout button, which resulted in the report being displayed correctly in landscape format. After that you "printed" the document in XPS format. When you opened that XPS document, it was being displayed in portrait instead of landscape. That is precisely what the problem is. Please see files attached:

sample video - this is the video you attached on 24/06
portrait - this is the way I get all my reports despite the fact that I change settings to landscape. Please also note that my reports have been configured in SSRS as landscape and they print fine there,
landscape - this is how I would like my reports to print

Currently I use export button as a workaround. When I export to PDF first and print from there, everything works fine. Unfortunately, using "Print" button from within ReportViewer control seems to be forcing portrait all the time.

Hope this clarifies the issue.

Thanks very much in advance,

Kind regards,
Tom



Attachment: Files_43f9e02d.zip

Yuvaraj Devarajan [Syncfusion]
Replied On July 20, 2016 01:45 AM

Hi Tomasz, 

A support incident has been created under your account. Please log on to our support website to check for further updates.    
     
Regards,  
Yuvaraj D.  


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;