We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

AllowEditOnDoubleClick results in poor rendering on the screen

Thread ID:

Created:

Updated:

Platform:

Replies:

124308 May 31,2016 10:47 AM UTC Jun 6,2016 12:39 PM UTC JavaScript 4
loading
Tags: ejGrid
duncan
Asked On May 31, 2016 10:47 AM UTC

If I enable 'AllowEditOnDoubleClick ' within the grid, if I double-click on a row to edit, & then double-click on another row without editing, the original row stays within edit mode in addition to the existing row.

Please can anybody advise on how I can get the rendering fixed here? I would expect this to work out of the box.

Regards,

Duncan

duncan
Replied On May 31, 2016 10:51 AM UTC




I've attached the image above to illutstrate the problem. I can't have it looking like this !

Regards,

Duncan

Venkatesh Ayothi Raman [Syncfusion]
Replied On June 1, 2016 12:09 PM UTC

Hi Ducan,   
  
Thank you for contacting Syncfusion support.   
  
We were unable to reproduce the issue at our end and created a sample for your reference.   
  
 Kindly share the following details for your query,   
  
1)      Essential Studio version details.   
2)      Provide Grid code example.   
3)      If possible send a sample or modify the given sample as issue reproducible.   
4)      Any kind of error thrown in console window? If so, provide screenshot.   
5)      Whether are you using remote data or local data? If so, provide more details about that.    


 
 
Note: If you are using remote methods to update/insert/delete a record then please ensure that the postback request fails while updating a record. For this case, the reported issue gets reproduced.   
  
Regards,   
Venkatesh Ayothiraman.   


duncan
Replied On June 3, 2016 10:46 AM UTC

I have found a work-around for this issue.

By applying the following setting I can ensure that when the row is existed that it is updated automatically and rendering returns to normal:

  enableAutoSaveOnSelectionChange :true

... it took me quite a while to figure this out by trial and error so if I'm supposed to be using combinations of settings to get the desired results with these controls then this needs to be documented by Syncfusion to prevent me wasting my valuable time.

Regards,

Duncan




Karthick Kuppusamy [Syncfusion]
Replied On June 6, 2016 12:39 PM UTC

Hi Duncan, 

Sorry for the inconvience caused. 

We have considered this “Editing with EnableAutoSaveOnChange” as improvement task of UG documentation and it will be included in any of the upcoming release.  

Please let us know if you have any further assistance. 

Regards, 
K.Karthick 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;