We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to set enable external Image on rdlc file and show on MVC report viewer.

Thread ID:

Created:

Updated:

Platform:

Replies:

120852 Oct 22,2015 09:01 AM UTC Oct 26,2015 04:53 AM UTC ASP.NET MVC 3
loading
Tags: ReportViewer
Apisage Tinnatechasit
Asked On October 22, 2015 09:01 AM UTC

I tried to set image control to load data from the url. such as "http://www.xxx.com/images/xxx.jpg". But it show blank image and when I checked html source image that show like below instaed "http://www.xxx.com/images/xxx.jpg"


<img src="/api/ReportAPI/GetResource/?key=FE1A79B7-9C8A-20C8-F101-DD729549584A^reportviewer_Image3_539c947a-1361-4ae6-9116-06a318f1f6af&amp;resourcetype=sfimg&amp;isPrint=false" style="width: 100%; height: 100%;">

Soundara Rajan S [Syncfusion]
Replied On October 23, 2015 05:28 AM UTC

Hi Apisage,

Thanks for contacting Syncfusion support.

We are unable to reproduce the mentioned issue and it is working fine at our end. We have prepared a working sample and it can be downloaded from the below location,
http://www.syncfusion.com/downloads/support/directtrac/145976/ze/ExternalImages642482672.zip

Please find the screenshot for the image load from the http link,


If the issue still persists, then share more information with your image reportItem used scenario in report. 

Regards,
Soundara Rajan S.

Apisage Tinnatechasit
Replied On October 23, 2015 02:34 PM UTC

Hi Soundara

I tried your sample already. It will ok when use your url "http://mvc.syncfusion.com/demos/web/Content/images/dashboard_img/stock_thumb.png" or some kind of url Syncfusion. But when I use other url in the below  that still show blank image. 

"http://www.google.com/images/branding/googlelogo/2x/googlelogo_color_272x92dp.png"

"https://assets.onestore.ms/cdnfiles/onestorerolling-1510-21005/shell/v2_5/images/logo/microsoft.png"


I changed only url of image control don't do anything more.

Attachment: invoice_demo_61e5a0f6.zip

Soundara Rajan S [Syncfusion]
Replied On October 26, 2015 04:53 AM UTC

Hi Apisage,

We are able to reproduce the mentioned issue and have logged defect report regarding this. A support incident to track the status of this defect has been created under your account. Please log on to our support website to check for further updates
https://www.syncfusion.com/account/login?ReturnUrl=%2fsupport%2fdirecttrac%2fincidents  

Regards,
Soundara Rajan S



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;