We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Am I First? Error attempting to run sample...SyncfusionUniversalWindows demo

Thread ID:

Created:

Updated:

Platform:

Replies:

119992 Aug 20,2015 01:20 PM Aug 26,2015 04:32 AM UWP 8
loading
Tags: General
Tony Thornton
Asked On August 20, 2015 01:20 PM

I am running Windows 10, VS 2015.  I downloaded the UWP Version 13.2.0.34 (Service Pack) (both the ZIP and the EXE) and I am unable to compile the sample.

When I try to run the sample, I get this error:  Could not find SDK "SyncfusionUniversalWindows, Version=13.2.0.34". Common_2015

Did anyone else have this problem?  Is there a fix?

TonyT

Victory Jessie Selvam D [Syncfusion]
Replied On August 21, 2015 07:27 AM

Hi Tony,

Thank you for using Syncfusion products.

We are unable to reproduce the reported issue "Compilation error in Universal Windows SampleBrowser". Kindly ensure the following SDK locations are available in your system and do the following steps to add them manually,

SDK locations:
[Drive]:\Program Files (x86)\Windows Kits\10\Extension SDKs\SyncfusionUniversalWindows
[Drive]:\Program Files (x86)\Syncfusion\Essential Studio\13.2.0.34\Universal Windows\10.0\SDK

Steps:
1) Right click on References in Common project
2) Select Add Reference
3) Choose Extensions under Universal Windows tab
4) Select Syncfusion controls for UWP XAML

Kindly get back to us with the build mode of Sample Browser if you are able to reproduce the issue even after following these steps.

Please let us know if you need further assistance on this.

Regards,
Jessie

Yang Jun
Replied On August 21, 2015 08:55 PM

I met the same issure.
Yes. You need to add SyncfusionUniversalWindows ref by yourself.

Victory Jessie Selvam D [Syncfusion]
Replied On August 24, 2015 06:41 AM

Hi Yang Jun,

Sorry for the inconvenience caused.

Still we are unable to reproduce the reported compilation error in Sample browser. Kindly add the Syncfusion Universal Windows SDK package manually to resolve it.

Please let us know if you need further assistance on this.

Regards,
Jessie

Tony Thornton
Replied On August 24, 2015 07:34 AM

I copied the contents of the C:\Program Files (x86)\Syncfusion\Essential Studio\13.2.0.34\Universal Windows\10.0\SDK into the 
C:\Program Files (x86)\Windows Kits\10\Extension SDKs\SyncfusionUniversalWindows\13.2.0.34 folder and then was able to get the sample to build and run.

Thank you for your help.  Shouldn't the install procedure be doing that already?  Is it working for others?  Maybe, should I have run the install program as Administrator?



Victory Jessie Selvam D [Syncfusion]
Replied On August 25, 2015 01:57 AM

Hi Tony,

Thank you for your update.

We are glad to know that your issue has been resolved finally.

Query #1: Shouldn't the install procedure be doing that already?
The installer will copy Syncfusion assemblies to Windows kit SDK location by default.

Query #2: Is it working for others? Maybe, should I have run the install program as Administrator?
Still we are unable to reproduce this issue in our side. We suspect that it may be due to some interruptive actions or keeping Visual Studio open during installation. By default, the installer will run as Administrator.

Please let us know if you need further assistance on this.

Regards,
Jessie

Victory Jessie Selvam D [Syncfusion]
Replied On August 25, 2015 04:37 AM

Hi Tony,

For checking the reported issue at our end, could you please follow the steps suggested in the below KB article link and send us the zip file which consists of Syncfusion Installer logs generated by our tool? It would be helpful for us to resolve the reported issue at the earliest.
http://www.syncfusion.com/kb/2331

Please let us know if you need further assistance on this.

Regards,
Jessie

Tony Thornton
Replied On August 25, 2015 08:05 AM

Done.  Please see incident # 143199

Victory Jessie Selvam D [Syncfusion]
Replied On August 26, 2015 04:32 AM

Hi Tony,

Thanks for the update.

Kindly follow the incident to get the issue resolved.

Please let us know if you need further assistance.

Regards,
Jessie

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;