We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date
Starting in 2019, the Reporting control is no longer included in Essential Studio. If you're experiencing issues with the Syncfusion Reporting Platform, Report Viewer, Report Designer, or Report Writer, we recommend migrating to Bold Reports, our dedicated reporting platform.

Bold Reports offers a comprehensive suite of tools and features for all your reporting needs, and we will help you make a smooth transition from the discontinued control. Our support team at https://support.boldreports.com/ is here to assist you with any questions or difficulties you may encounter during the migration process.

We thank you for choosing Syncfusion and appreciate your understanding.

report viewer showing error after updating Syncfusion version

Hi Team,

I have the following error, while loading my report in report viewer.
It was working fine all along. Just after upgrading to I think 13.2.0.29, I begin to encounter this error.
Attaching screen shot also
Thank you.

Jianwei

Unable to load Reportitem 'Tablix5' Getting following error : Conflict detected when trying to save CoveredCellInfo ( Top = 4 Left = 4 Bottom = 4 Right = 5 SpanWholeRow = False SpanWholeColumn = False ClipRows = False ClipColumns = False )
 StackTrace:
   at Syncfusion.Windows.Controls.Cells.CellSpanInfoCollection`1.CellSpanPool.AddCellSpan(T item)
   at Syncfusion.Windows.Controls.Cells.CellSpanInfoCollection`1.Add(T item)
   at Syncfusion.RDL.Controls.ReportingTablixControl.UpdateCellValues()
   at Syncfusion.RDL.Controls.ReportingTablixControl.SetCellValues()
   at Syncfusion.RDL.Controls.ReportingTablixControl.UpdatePage()
   at Syncfusion.Windows.Reports.Viewer.ReportViewer.DrawBodyControls(ReportModelContentCollection reportModelCollection, Boolean isPrintLayout)

Attachment: Issue_Details_ea7c1eb1.zip

3 Replies

MP Mohanapriya Perumakarasu Syncfusion Team August 5, 2015 06:18 PM UTC

Hi Wang,

Thanks for using Syncfusion Products.

We regret to inform you that we have tested mentioned issue with the shared snap, but we are unable to reproduce this issue. However, we have prepared runnable sample based on this and it can be downloaded from below link.

Sample : http://www.syncfusion.com/downloads/support/directtrac/140578/ze/DemoSample1327559696

If you still face any issues on this, could you please share the sample ReportDefinition of your report? It will be helpful for us to provide a solution earliest.
Please let us know if you have any questions.
Regards,
P.Mohanapriya


WJ Wang Jianwei August 6, 2015 06:49 AM UTC

I discover that it's a cell merging which caused the error.
I have split the cells, and it is working fine now.
Thx.


NB Nithya B Syncfusion Team August 7, 2015 11:11 AM UTC

Hi Wang,

Thanks for your update.

Please let us know if you need any further assistance. As always, we will be happy to assist you.

Regards,
Nithya B

Loader.
Live Chat Icon For mobile
Up arrow icon