We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

MouseWheel Scrolling on classic ASP.NET gridgroupingcontrol

Thread ID:

Created:

Updated:

Platform:

Replies:

118889 Apr 20,2015 03:47 PM UTC Apr 24,2015 12:35 PM UTC ASP.NET Web Forms (Classic) 5
loading
Tags: GridGroupingControl
Graham Gardner
Asked On April 20, 2015 03:47 PM UTC

I have used the grid grouping control on several pages on a website and have noticed that using the mousewheel to scroll through the records in these tables only seems to work if the mouse cursor is actually over the vertical scrollbar. If you use the mouse wheel over the records themself the whole page seems to scroll rather than the table.
 
How do I set the gridgroupingcontrol (properties etc) so that when the mouse is over the records that when the mousewheel is used the table scrolls up and down as it does when mouse is over the vertical scrollbar?
 

Version 11.3040.0.30


Shanmugaraja K [Syncfusion]
Replied On April 21, 2015 05:16 PM UTC

Hi Graham,

Thanks for using Syncfusion products.

We have analysed your requirement. We suspect that you have been using Frozen rows or Frozen columns with scrolling, we would like to let you know that the issue has been fixed in our latest version and we suggest you to upgrade to the latest version. Latest version can be downloaded from the following link.

Download link: http://www.syncfusion.com/downloads/latest-version

Please let us know if you need further assistance.

Regards,Shanmugaraja K


Graham Gardner
Replied On April 22, 2015 04:03 PM UTC

Ok I have installed version 13.1400.0.21 and yes it does now scroll when cursor is over the records as well as  the scroll bar, thank you.

One further thing with the scrolling, is it possible to increase the scroll step for each turn of the mousewheel it seems to be quite small currently.

NOTE: I am using the web forms gridgroupingcontrol and not the windows forms version, I have been looking through the documentation and most scrolling settings seem to apply to the windows forms control only.

Shanmugaraja K [Syncfusion]
Replied On April 23, 2015 12:23 PM UTC

Hi Graham,

Thanks for your update.

Before we start to providing you a solution, could you please update us the following information?

1. How many records you have rendering in your Grid?

2. Did you useGrid pager in your sample?

3. If, you are using the Grid pager in your sample, please let us know how many records you have rendering in single page.

Please share the above information with us, so that we can work on this and provide you a better solution.

Please let us know if you need further assistance.

Regards,

Shanmugaraja K


Graham Gardner
Replied On April 23, 2015 12:32 PM UTC


The Grids I have do use the Grid Pager, and the user can select from 5 options the number of records displayed per page


10 The Default number

25

50

75

100


Thanks


Shanmugaraja K [Syncfusion]
Replied On April 24, 2015 12:35 PM UTC

Hi Graham,

Thanks for your update.

We considered this [“Mouse wheel scroll small with frozen rows”] as an issue and a support incident has been created under your account to track the status of this requirement. Please log on to our support website to check for further updates.

https://www.syncfusion.com/account/login?ReturnUrl=/support/directtrac/incidents

Please let us know if you need further assistance.

Regards,Shanmugaraja K


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;