We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

How do I keep report headers at the top of the page?

Thread ID:

Created:

Updated:

Platform:

Replies:

118830 Apr 13,2015 06:08 PM Apr 14,2015 02:46 AM JavaScript 1
loading
Tags: ejReportViewer
Waldemar Sauer
Asked On April 13, 2015 06:08 PM

I have a few issues regarding the headers for my reports for both on screen and print. If there are workarounds for the below issues, please let me know and I can try them out.

I tried the following, but it does not seem to be working for me:
  • Add a table to a report (in Visual Studio).
  • Right click on the header row, and select Tablix Properties...
  • Under "Row Headers" for the general tab, I select both the following:
  1. "Repeat header rows on each page"
  2. "Keep header visible while scrolling".
When there are enough items in the report so that a scroll bar appears, when I use the scroll bar, I do not see the report headers stick to the top of the report viewer control.

Also, when I export to Excel, the headers are not preserved on each page.

Also, exporting to pdf does not consider the Landscape setting when I perform Page Setup.

-Waldemar


Soundara Rajan S [Syncfusion]
Replied On April 14, 2015 02:46 AM

Hi Waldemar,

Thanks for using Syncfusion Products and Sorry about inconvenience caused.

I have a few issues regarding the headers for my reports for both on screen and print. If there are workarounds for the below issues, please let me know and I can try them out.
I tried the following, but it does not seem to be working for me:
Add a table to a report (in Visual Studio).
Right click on the header row, and select Tablix Properties...
Under "Row Headers" for the general tab, I select both the following:
"Repeat header rows on each page"
"Keep header visible while scrolling".
When there are enough items in the report so that a scroll bar appears, when I use the scroll bar, I do not see the report headers stick to the top of the report viewer control.
Also, when I export to Excel, the headers are not preserved on each page.
We have checked this with MS ReportViewer, we are getting same behavior in Syncfusion ReportViewer as like MS ReportViewer. So we request to you following below steps to achieving your requirement,
1) Click on the small black down arrow on the far right of the grouping pane and select the Advanced Mode property as shown by below screenshot.

2) Select the corresponding (Static) item in the row group hierarchy and set the RepeatOnNewPage to true as shown by below snap,

For your convenience, We have prepared sample based on this and it can be downloaded from below location,
http://www.syncfusion.com/downloads/support/forum/118830/RDLDemo-1531534429.zip
Please refer below MSDN link more details on this,
https://social.msdn.microsoft.com/Forums/sqlserver/en-US/ee29da49-5c8c-47f3-a905-c730dcbe9780/tablix-headers-not-repeating-in-ssrs-2008
Also, exporting to pdf does not consider the Landscape setting when I perform Page Setup.
We are unable to reproduce this issue and we prepared video demo for page setup landscape setting is working fine in our end and it can be downloaded from below link,
http://www.syncfusion.com/downloads/support/forum/118830/PrintLayout-290437251.zip
If you still face any issues regarding this, then could you please share much more details regarding this?. It will be helpful analyze this issue and provide the solution to earlier.

Please let us know, if you have any concerns.

Regards,
Soundara Rajan S.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;