We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

GridDataControl filter functionality

Thread ID:

Created:

Updated:

Platform:

Replies:

117940 Jan 12,2015 03:00 AM UTC Jan 13,2015 12:47 PM UTC WPF 3
loading
Tags: GridDataControl
vincent
Asked On January 12, 2015 03:00 AM UTC

Currently, we use GridDataControl with filter functionality, however, when there's horizontal scroll bar in the data grid, and you remove it forth and back, lots of weird things related to filter functionality happened. (See attachment.)
I thought this is caused by partial refresh, I mean in our code, we use GridDataControl.Model.View.Refresh() to refresh the datagrid, but it will not refresh filter window and scroll bar.
So, Is there a method for refresh all of the control in the datagrid?


Attachment: 1_12e3963b.zip

Jayapradha S [Syncfusion]
Replied On January 12, 2015 03:14 PM UTC

Hi Vincent,

Thank you for using Syncfusion products.

We have analyzed your query and we are unable to reproduce your reported issue when using Filters as shown in your provided screenshot. We didn’t use any external method to refresh the grid. Grid gets automatically refreshed.

We have created a sample and please find the sample from the below location,

Sample Link: 117940.zip

Please have a look at the sample and if the issue still exists at your end, could you please try to reproduce  it in the above sample.

Could you please share any operations you have trying to do when move the horizontal scrollbar back and forth and then filter the records?

It will be help us to provide a better solution..

Please let us know if you have any queries.

Regards,

Jayapradha




vincent
Replied On January 13, 2015 02:43 AM UTC

Hi Jayapradha S,

The bug has been reproduced, I just used the code you provided, and changed the reference library to the version we are using. (version 11.2040.0.25)
Please see the attachment, previously I thought we didn't use it correctly, but now I think it's the control bug.


Attachment: GridDataControl_d7ed4b9d.zip

Jayapradha S [Syncfusion]
Replied On January 13, 2015 12:47 PM UTC

Hi Vincent,

We are sorry about the inconvenience.

We have checked the sample which was provided in our previous update in 11.2 V. still we are unable to reproduce the reported issue.

Please find the video clip from the below location,

Video Clip: 117940.zip

Could you please share your video clip to replicate the issue at our end. It would be help us to provide a better solution.

Regards,

Jayapradha




CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;