We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Diagram controll image not rendering

Thread ID:

Created:

Updated:

Platform:

Replies:

107932 Mar 25,2013 02:55 AM Apr 1,2013 02:54 AM ASP.NET Web Forms (Classic) 1
loading
Tags: DiagramWebControl
moiz
Asked On March 25, 2013 02:55 AM

I am trying use Syncfusion diagram web control in my application. The controls/images (Rectangle, Ellipse) are not displaying in the browser.

I have added following in we.config but no luck

<add verb="*" path="ImgRequest.ashx" type="Syncfusion.Web.UI.WebControls.Diagram.NodeRenderHandler,Syncfusion.Diagram.Web, Version=10.204.0.75, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89" />
      <add verb="*" path="PaletteImgRequest.ashx" type="Syncfusion.Web.UI.WebControls.Diagram.ThumbNodeRenderHandler,Syncfusion.Diagram.Web, Version=10.204.0.75, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89" />
      <add verb="*" path="OverviewImgRequest.ashx" type="Syncfusion.Web.UI.WebControls.Diagram.OverviewDocumentRenderHandler,Syncfusion.Diagram.Web, Version=10.204.0.75, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89" />   


--------------
 FYI, I am using the version 10.204.0.75. Please suggest me the solution.   

Pandi Murugan A [Syncfusion]
Replied On April 1, 2013 02:54 AM

Hi Moiz,

 

Thanks for using Syncfusion products.

 

We suggest you to add the diagram handlers under <system.webServer> <handlers><!--Diagram handlers here--></handlers></system.webServer> when you host your application in the web server.

 

Please refer the below.

 

<code>

<system.webServer>

<handlers>

<add name='ImgRequest' path='ImgRequest.ashx' verb='*' type='Syncfusion.Web.UI.WebControls.Diagram.NodeRenderHandler, Syncfusion.Diagram.Web, Version=10.204.0.75, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' resourceType='Unspecified' preCondition='integratedMode' />

      <add name='PaletteImgRequest' path='PaletteImgRequest.ashx' verb='*' type='Syncfusion.Web.UI.WebControls.Diagram.ThumbNodeRenderHandler, Syncfusion.Diagram.Web, Version=10.204.0.75, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' resourceType='Unspecified' preCondition='integratedMode' />

      <add name='OverviewImgRequest' path='OverviewImgRequest.ashx' verb='*' type='Syncfusion.Web.UI.WebControls.Diagram.OverviewDocumentRenderHandler, Syncfusion.Diagram.Web, Version=10.204.0.75, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' resourceType='Unspecified' preCondition='integratedMode' />

</handlers>

</system.webServer>

</code>

 

Please let me know if any concerns.

 

Regards,

Pandi Murugan A


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;