We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Could not load file or assembly ''Syncfusion.Core, Version=8.304.0.21

Thread ID:

Created:

Updated:

Platform:

Replies:

102325 Jan 19,2012 02:51 PM Feb 10,2012 06:20 AM ASP.NET Web Forms (Classic) 4
loading
Tags: GridGroupingControl
Greg Chang
Asked On January 19, 2012 02:51 PM

Development Enviroment:
Visual Studio 2010.
.NET Framework 4
ASP.NET MVC3
Syncfusion 8.304.0.21

Trying to use syncfusion MVC grid.
Added follwing references:
Syncfusion.Core
Syncfusion.Linq.Base
Syncfusion.Shared.Mvc
Syncfusion.Grid.Mvc
Syncfusion.Shared.Base
All have Copy Local: True
Specific Version: False

Web.config:






------------------------------------------------------------
Application project build no problem, when lauch the application get following error:
Parser Error Message: Could not load file or assembly 'Syncfusion.Core, Version=8.304.0.21, Culture=neutral, PublicKeyToken=632609b4d040f6b4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:


Line 37:
Line 38:
Line 39:
Line 40:
Line 41:





Greg Chang
Replied On January 20, 2012 11:37 AM

Not an issue anymore, it is referenced assembly version different from config file.


Sridhar N [Syncfusion]
Replied On January 23, 2012 11:03 PM

Hi Greg,

Thanks for your interest in Syncfusion products.

We are happy to hear that your issue is resolved.

Please let me know if you have any other questions or concerns.

Regards,
Sridhar N


Frank van Bokhoven
Replied On February 8, 2012 04:53 AM

I have the same error. I am pretty conficed i have the right assembly in my project, but it keeps giving the exact same error as mentioned in the start of this topic.

For anyone else who reads for help about this error: how should we tackle this? Where are the assemblies located that the solution thinks are incorrect versioned?

regards,

Frank


Sridhar N [Syncfusion]
Replied On February 10, 2012 06:20 AM

Hi Frank,

Thanks for your update.

We suggest you to check the following.

1. Referenced assembly and web.config version are same.

2. There should be no dll in bin if referenced from GAC. Please clean solution before build.

3. Check whether there is conflict between MVC2 and MVC3. Please refer the below link

Note: To know more about the steps to switch between (Mvc2 to Mvc3) , please refer the document here :

http://help.syncfusion.com/resources/Content/Ug_101/User%20Interface/ASP.NET%20MVC/Grid/documents/612howtoswitchbetwee.htm


Please let us know if you need further assistance.

Regards,
Sridhar N


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;