We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

MVC 3 Grid - Deployment issue

Thread ID:

Created:

Updated:

Platform:

Replies:

101848 Nov 28,2011 05:50 AM UTC Jan 3,2013 04:07 AM UTC ASP.NET MVC (Classic) 5
loading
Tags: Grid
Administrator [Syncfusion]
Asked On November 28, 2011 05:50 AM UTC

Hello Experts,

Everytime, when I deployed the application on the server and tried to access that deployed application first time, i always get an error "Registering style sheet for the Grid failed because assembly does not exist.". Once we got this error and tried to access that deployed application again than it works fine but when we access it first time we always get that error.

Please find error as an attachment.

Thanks
Alok Shah



SyncfusionGridStyleSheetError_e33f644c.rar

Eswari S [Syncfusion]
Replied On November 29, 2011 09:38 AM UTC

Hi Alok,

Thank you for using Syncfusion products.

Query #1: i always get an error "Registering style sheet for the Grid failed because assembly does not exist

Sorry for the inconvenience caused. We were unable to reproduce the issue. We have deployed the sample in online without any issue. Please refer to the following online link:

http://files2.syncfusion.com/demos/MVC/Grid-Razor

Also ,we would request you to ensure whether the following listed assembly have been included in the reference.
• Syncfusion.Core.dll
• Syncfusion.Grid.Mvc.dll
• Syncfusion.Linq.Base.dll
• Syncfusion.Shared.Mvc.dll
• Syncfusion.Compression.Base.dll
• Syncfusion.XlsIO.Mvc.dll
• AjaxMin.dll
• Syncfusion.DocIO.Mvc.dll
• Syncfusion.Pdf.Base.dll

Please refer to the online UG link :

http://help.syncfusion.com/ug_94/User%20Interface/ASP.NET%20MVC/Grid/default.htm?turl=Documents%2Fdll.htm

Please try this and let us know if you have any other queries.

Regards,
Eswari.S



Mijail O Tornes
Replied On September 5, 2012 12:14 PM UTC

Hello,

I´ll like to know if this issue was fixed somehow.
We are facing the same issue but instead of the first time, it happening minutes later after the deployment was done, and it is a permanent issue. 
Re-deploying or overtiring the MVC Grid dll with a copy of itself fixes the issue every time, but again, just for a short time. 

Rakesh D [Syncfusion]
Replied On September 14, 2012 06:26 AM UTC

 

Hi Mijail,

 

Thanks for using Syncfusion products.

 

Could you please provide us the following details to investigate further on this issue?

 

1.     1. Current Syncfusion Essential Studio Version that is used in your deployment machine.

2.      2. Names of Syncfusion MVC product in your project like Grid, Mobile Grid MVC, Schedule, Chart etc.

 

Please let us know if you have any concerns.

 

Regards,

Rakesh D


Stefan Onken
Replied On November 4, 2012 03:07 PM UTC

I have the same issue. It seems to happen with a "cold start" of the web application. e.g when the web was shut down due to longer inactivity. When the error message is shown in your browser (see attachment) and you hit F5 everything works fine until the next shutdown of the web. I am registering the Syncfusion style manager in my _Layout.cshtml. All used assembly are taken from Essential Studio Version 10.3.0.43

Any solutions found?

Stefan


syncfusion error_4763a5ac.zip

Ranjithkumar R G [Syncfusion]
Replied On January 3, 2013 04:07 AM UTC

Hi  Stefan,

 

Thanks for using Syncfusion products.

 

We  regret for the inconvenience caused.  We are unable to reproduce your reported issue. In the meanwhile, we suggest you to remove Stylesheet for Grid in Site.Master to resolve your reported issue . We would like to inform you that Registering stylesheet for the Grid in the Site.Master will refer the CSS file of Grid in the 'head' tag. If we do not register the stylesheet for the Grid in Site.Master , it will refer the CSS file of Grid in the 'body' tag just before the Grid renders, which will not cause any other issues further. So, we suggest you to remove the Stylesheet of Grid in Site.master to resolve the issue at your end.

 

Please get back to us if the above method does not resolve your issue.

 

Regards,

Ranjithkumar.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;