We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

SyncFusion Licensing Error

Thread ID:

Created:

Updated:

Platform:

Replies:

101615 Nov 8,2011 06:09 AM Nov 21,2011 06:56 AM General Discussion 6
loading
Tags: General Discussion
prashanthi
Asked On November 8, 2011 06:09 AM

Dear Sir/Madam,

In my project i am using sync-fusion of Version 6.3.0.32 for VS2005 application,now i am trying to upgrade my project into VS2010 version,here i am getting an error box of license issue telling that "Syncfusion Licensing Runtime was not able to detect an entry for Syncfusion Controls in this project's licx File."

Can you please tell me How do i Clear this error?

Thanks,
Prashanthi.



SyncFusion Licensing Error_1fe86093.rar

Sivaguru S [Syncfusion]
Replied On November 9, 2011 11:45 AM

Hi Prashanthi,

Thanks for using Syncfusion Products.

Could you Please follow the below mentioned steps to resolve the licensing issue.

1)If you are using Syncfusion version after 8.2.x.x ,Remove the license.licx file from your project, Because Syncfusion had removed run-time licensing for all Essential Studio products from the version 8.2.0.x.

2)To upgrade your projects to the latest version.

We have a project migration tool in our latest version(9.3.0.61) which is used to migrate project from one version to another version.

Please find the project Migration tool from the below location:

Start->All programs->Syncfusion->Essential studio 9.3.0.61->Tools->Project Migration-> Syncfusion Project Migration

Or

You can find the utility from the below installed location.

{Installed location}\ Syncfusion\Essential Studio\ {Essential Studio version}\Utilities\ProjectMigration\ProjectMigrationWindows.exe

For ex:

C:\Program Files\Syncfusion\Essential Studio\9.3.0.61\Utilities\ProjectMigration\ProjectMigrationWindows.exe

If you want to manually upgrade project from one version to another version, then please follow the below KB article.

http://www.syncfusion.com/support/kb/2137

Please let us know ,if you have any queries.

Regards,

Sivaguru S.


prashanthi
Replied On November 12, 2011 07:30 AM

Hi Sivaguru,

We are currently using Syncfusion of version 6.3.0.32 and that too a customized code which is perfectly working with VS2005. As we are migrating to VS2010, we want those customized Syncfusion dll's to be referenced. When we try to do the same, we are facing the license error. Mean, we are getting the "Fix it" Dialogue, each time we run the application.

Please find the attached Screen Shots of License Error.

Can u please help on this.

Thanks in Advance,
Prashanthi.



Licencing Error_c6258d.rar

Sivaguru S [Syncfusion]
Replied On November 14, 2011 06:14 AM

Hi Prashanthi,

Thanks for using Syncfusion Products.

We provides the complete support for Visual Studio 2010 from Essential Studio v8.2.0.18 onwards. Upgrading your project to newer version do not affect the existing behavior of your project.

Follow the below KB article to resolve runtime licensing issue.

http://www.syncfusion.com/support/kb/2124

If you wish to upgrade your projects to another version, then please follow the migration steps as mentioned in previous update.

Please let us know if you have any queries.

Regards,
Sivaguru S.



prashanthi
Replied On November 15, 2011 05:44 AM

Hi Sivaguru,

Thanks for the reply,

Actually we don't want to migrate from version 6.0 to upgraded version. My application is running perfectly with version 6.0 of sync fusion.

Only the thing is we need to upgrade our .NET code from .NET Framework 2.0 to 4.0. Just let me know is it possible to use Sync fusion 6.0 version (i.e., developed with .NET ver 2.0) with Visual Studio 2010 (.NET Framework 4.0) without any conflict.

If works fine please let me know the details how to migrate.

Thanks for your immediate attention !

Regards,
Prashanthi


prashanthi
Replied On November 16, 2011 06:17 AM

Hi Sivaguru,

Thanks for your reply,

Actually we are using Syncfusion 6.3.0.32 API into one of my .NET 2.0 based windows application. With .NET 2.0 we don’t have any issue and we are using since last couple of years. Recently we want to migrate the our source code in .NET 4.0, but still we want to use Syncfusion DLL version 6.3.0.32. Here we are getting licensing error as shown below. But some of the times (may be for some controls) we are not getting any license error and syncfusion controls are displayed properly.

The sync fusion error message is :

Please refer IMG1.jpeg

After clicking on Fix it we are getting the following dialog.

Please refer IMG2.jpeg

But the problem is every time we are running the application we are getting this Licensing Error message. Just let me know what is happening under Fix It.

In addition can we use SyncFusion 6.3.0.32 DLL with .NET 4.0 based windows application without any license upgrade or any other changes.

In addition some of the syncfusion DLL’s we have source code (We customized code) with us, and we build these code with .NET 4.0 but SyncFusion.Core.dll we don’t have source code and this is compiled with .NET 2.0. Please look in this aspect also is there any issue arising. The below is sync fusion projects screenshot.

Please refer IMG3.jpeg

Thanks for your immediate attention !


Regards,
Prashanthi









SyncFusionLicensingIssue_9f65f89e.rar

Sivaguru S [Syncfusion]
Replied On November 21, 2011 06:56 AM

Hi Prashanthi,

Sorry for the delay in getting back to you.

Please find my response for your queries.

1) What is happening under Fix It?

A) Fix it will check for respective version's valid license in registry, if the License key is accepted by 'Syncfusion.Core' it won't show the license error again.

2) Can we use SyncFusion 6.3.0.32 DLL with .NET 4.0 based windows application without any license upgrade or any other changes?

No. We provides the complete support for Visual Studio 2010(.Net 4.0 ) from Essential Studio v8.2.0.18 onwards. If you get license for our syncfusion products, you can upgrade to any of our latest version(9.4.0.62), Please contact support@syncfusion.com for license subscription.

3) Is there any issue arising when the syncfusion.core dll with .NET 2.0 and other assemblies with .net 4.0 framework?

Yes. The same 2.0 'Syncfusion.Core' assembly will not resolve the license error when you use it in the application which targets 4.0 framework. You should refer the 'Syncfusion.Core' assembly of framework 4.0.

Please let us know if you have any queries.

Regards,
Sivaguru S


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;