We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. Image for the cookie policy date

swipe and drag broken on Forms.IOS in ListView - FIX

Unfortunately I can't reproduce it, but if you've recently experienced a broken ListView in that items cannot be swiped or dragged, and your item template contains a Frame with a Visual of Material - then switch the Visual to Default, and you should have the functionality back again.

related thread
https://www.syncfusion.com/forums/148220/sflistview-17-0-3-14-visual-quotmaterialquot-swipe-problem

3 Replies

MM Mageshyadav M Syncfusion Team October 28, 2019 09:41 AM

Hi Malcolm , 
 
We have checked the provided sample and we able not to reproduce the reported issue with update versions of SfListView. We let you know that version 17.3.0.14 has some issues with Visual as Material, if you are using that particular version, we suggest you to updated versions of SfListView 17.3.0.17 or later. And also we prepared the sample for same for your reference. Can you please check with our sample and revert back with us whether the issue has been resolved at your end.  
 
 
Regards 
Gokul Saravanan 



JB John Burrows replied to Malcolm Jack November 22, 2019 07:16 PM

Unfortunately I can't reproduce it, but if you've recently experienced a broken ListView in that items cannot be swiped or dragged, and your item template contains a Frame with a Visual of Material - then switch the Visual to Default, and you should have the functionality back again.

related thread
https://www.syncfusion.com/forums/148220/sflistview-17-0-3-14-visual-quotmaterialquot-swipe-problem

I have exactly the same problem on IOS 13.2. but not on Android

Turning Material to Default fixed the issue

Listview Version 17.3.0.27
Xamarin Forms 4.3.0.991211
Using Shell navigation




GP Gnana Priya Namasivayam Syncfusion Team November 25, 2019 05:18 AM

Hi Malcolm, 
  
We have checked the reported issue with the mentioned versions of ListView and Xamarin.Forms and also checked with the latest version but the reported issue did not occur from our end. We have attached the sample and video in iOS for your reference, kindly find the sample from the following link. 
  
  
  
Can you please check the provided sample and let us know whether the reported issue replicated in our sample also. If not please revert us back with the issue replicated or the modified sample so that we could able to analyze and provide you appropriate solution at our end. 
  
Regards, 
Gnana Priya N 


Loader.
Live Chat Icon For mobile
Up arrow icon