We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Report server scheduling - Email sent through Report server has corrupted attachment.

Thread ID:

Created:

Updated:

Platform:

Replies:

140706 Nov 1,2018 10:37 PM UTC Dec 10,2018 12:38 PM UTC Report Platform 8
loading
Tags: Report Server
Amanpreet
Asked On November 1, 2018 10:37 PM UTC

Hi Team,

I am using gmail SMTP settings and trying to schedule reports to be emailed to a group of users. I am able to successfully schedule the reports and also emails are being recieved on the users side. But, the report attachment which is part of the email is either corrupted or invalid because if I try to open the attachment through email it says "Adobe acrobat reader couldn't open pdf because it is either unsupported type or file is damaged." Also I tried scheduling emails in other formats, I am still getting blank attachments. This is only occuring with the reports which I am generating on company's database. Scheduling on template reports works fine. Please help me with resolving this issue.

Looking forward to see your response.

Thanks,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On November 2, 2018 12:47 PM UTC

Hi Amanpreet, 
  
Can you please confirm whether the problem occurring reports is viewed and exported properly without any errors as shown below ? Since this information will be useful for us to segregate the issue cause whether problem is there only in scheduling or problem raises when previewed and exported manually in server also. 
 
 
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On November 2, 2018 01:09 PM UTC

Hi Mageshyadav,

The problem doesn't occur when I view and export the report on the report server. This is only occurring while scheduling the reports which I have created on company's database. I do get email and also the report as attachment. But the attachment is corrupted and when I try to open it says it is unsupported type and size of the attachment is like 139 B.

Looking forward to see your response. Let me know If you need more inputs from my side.

Thanks,
Amanpreet

Mageshyadav M [Syncfusion]
Replied On November 5, 2018 09:22 AM UTC

Hi Amanpreet,  
 
We are unable to reproduce the reported issue. Can you please share us below details? It will be helpful for us to track the issue and provide a proper solution.    
    
  1. Report server log files from the deployed location. Please refer below KB to collect and share log files.  
 
 
  1. Report server hosted windows OS details.
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On November 5, 2018 02:19 PM UTC

Hi Mangeshyadav,

Please find below the details -

1. Report server log files from the deployed location attached.
2. Report server hosted windows OS details - Windows Server 2012 R2

This issue is during scheduling custom reports from report server.

Regards,
Amanpreet

Attachment: Logs_2b4322b5.zip

Mageshyadav M [Syncfusion]
Replied On November 7, 2018 09:38 AM UTC

Hi Amanpreet, 
 
Based on your logs shared, we are unable to determine the actual issue cause for reported issue. Hence we would like to setup a web meeting to look on your side and provide solution. To get your meeting availability and share meeting link, we have created a support incident under your account. Please log on to our support website to check for further updates in the incident created related to this forum.   
    
 
Regards, 
Mageshyadav.M 


Amanpreet
Replied On November 8, 2018 11:38 PM UTC

Hi Team,

Thank you for your support on the call. It has fixed the issue.

Regards,
Amanpreet

Johan van der Westhuizen
Replied On December 8, 2018 07:40 PM UTC

Was this sorted as I am not getting joy with the same problem.

Mageshyadav M [Syncfusion]
Replied On December 10, 2018 12:38 PM UTC

Hi Johan,  
 
The attachments in the schedule can be exported without any issue only when the report doesn’t require any of the following additional inputs to view the reports either in designer or server.  
 
  • Credentials of the datasource
  • Choose values for the parameters of the report
 
And we suspect that due to any of the reason, the attachment is received as corrupted. Please make sure that we don’t need any additional input to view report either in designer or server.  
 
Regards, 
Mageshyadav.M 


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;