We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

AutoComplete field not rendered (not visible) on iOS (Xamarin.Forms)

Thread ID:

Created:

Updated:

Platform:

Replies:

125528 Aug 23,2016 02:18 AM Apr 13,2017 07:28 AM Xamarin.Forms 8
loading
Tags: SfAutoComplete
Thomas Bomberg
Asked On August 23, 2016 02:18 AM

Hi,

I have an Xamarin.Forms application. It works fine on Android device, however AutoComplete field is not visible on iOS (both physical device iPhone 5s and simulators).
I tried both my application and sample.
Please suggest how to fix it. Thanks in advance.

Hemalatha Marikumar [Syncfusion]
Replied On August 24, 2016 04:34 AM

Hi Thomas Bomberg,

Thanks for contacting Syncfusion Support.

We were unable to reproduce the reported issue " AutoComplete is not rendered in iOS Xamarin ". We have attached a sample to test the issue for your reference in the below location.

Link: http://www.syncfusion.com/downloads/support/forum/125528/ze/TestingSampleForms317052206

Note: Please create an instance of SfAutoCompleteRenderer in AppDelegate.cs class as per the following code example 
  
public override bool FinishedLaunching(UIApplication app, NSDictionary options)

{

global::Xamarin.Forms.Forms.Init();

new SfAutoCompleteRenderer();

LoadApplication(new App());

return base.FinishedLaunching(app, options);

}


For more information about “adding renderer” check the user documentation from the following link

Link: https://help.syncfusion.com/xamarin/sfautocomplete/getting-started 

Please check the sample and if the issue still persists, update the modified sample or the replication procedure to analyze further and provide an appropriate solution

Regards,
Hemalatha M.R.
 


Robyn Hukin
Replied On August 24, 2016 08:10 PM

Hi Thomas Bomberg,

Thanks for contacting Syncfusion Support.

We were unable to reproduce the reported issue " AutoComplete is not rendered in iOS Xamarin ". We have attached a sample to test the issue for your reference in the below location.

Link: http://www.syncfusion.com/downloads/support/forum/125528/ze/TestingSampleForms317052206

Note: Please create an instance of SfAutoCompleteRenderer in AppDelegate.cs class as per the following code example 
  
public override bool FinishedLaunching(UIApplication app, NSDictionary options)

{

global::Xamarin.Forms.Forms.Init();

new SfAutoCompleteRenderer();

LoadApplication(new App());

return base.FinishedLaunching(app, options);

}


For more information about “adding renderer” check the user documentation from the following link

Link: https://help.syncfusion.com/xamarin/sfautocomplete/getting-started 

Please check the sample and if the issue still persists, update the modified sample or the replication procedure to analyze further and provide an appropriate solution

Regards,
Hemalatha M.R.
 


Hi Hemalatha,

I guess we are also having the same issue. Please find the attached sample.

Regards


Attachment: TestingSampleFormsBugReplicated_b16f0f56.zip

Pavendhan Kumar [Syncfusion]
Replied On August 25, 2016 08:12 AM

Hi Thomas,

Query: AutoComplete field not rendered on iOS.

We were able to reproduce the issue “AutoComplete field not rendered on iOS”. We have already logged a bug and fixed. The patch for the fix will be available in our upcoming 2016 Volume2 SP2 release which is expected to be rolled out by the end of August 2016.

Regards,
Pavendhan K.


Thomas Bomberg
Replied On August 28, 2016 05:23 AM

Hallo,

thanks for your answers.

adding this line helped:

new SfAutoCompleteRenderer();

Pavendhan Kumar [Syncfusion]
Replied On August 29, 2016 02:49 AM

Hi Thomas,

Thank you for your update.

Please let us know if you need any other assistance.

Regards,
Pavendhan K.

Guy Lemire
Replied On April 12, 2017 01:02 PM

Hello,
I am having the same issue, I am using MVVM and I just want to display a static list for now, the autocomplete does not render on the page in IOS 10.3 simulator

Constructor in View Model

public List<ComboBoxData> Items = new List<ComboBoxData>();

public ViewModel()
        {
            Items.Add(new ComboBoxData() { text = "25643", value = "PRO25643" });
            Items.Add(new ComboBoxData() { text = "25633", value = "PRO25633" });
            Items.Add(new ComboBoxData() { text = "24533", value = "PRO24533" });
            Items.Add(new ComboBoxData() { text = "25433", value = "PRO25433" });
            Items.Add(new ComboBoxData() { text = "26789", value = "PRO26789" });
        }

AppDelegate

new SfAutoCompleteRenderer();

XAML

<autocomplete:SfAutoComplete x:Name="Search" DisplayMemberPath="text" DataSource="{Binding Items}" />

XAML.cs

BindingContext = new ViewModel();

What is the problem?


Guy Lemire
Replied On April 12, 2017 01:30 PM

Sorry, the documentation should say that HeightRequest & WidthRequest are mandatory, now it displays when I added them with values.

Vanaja  Annasamy [Syncfusion]
Replied On April 13, 2017 07:28 AM

Hi Guy,

Thank you for contacting Syncfusion support.

We suggest you to use SfAutoComplete control inside StackLayout because the control will be displayed in full screen so the dropdownitems does not get displayed. Thank you for your suggestion and we will mention the same in the documentation.

Regards,
Vanaja R.A.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;