We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to NOT HANDLE the F10 key?

Thread ID:





97612 Dec 16,2010 03:41 PM UTC Dec 22,2010 06:38 AM UTC WPF 4
Tags: Tools
Asked On December 16, 2010 03:41 PM UTC

Hi there!

I am trying to Host Telnet inside WPF (Syncfusion RibbonWindow ), and I am handling some Hot Keys (F1,....F10,...); however, the RibbonWindow does not send the "F10" down to the Telnet (it disable all the "F" keys).

What can I do to let all the keys just fire all events when they are pressed without handling anything (such as disable all the "F" keys when pressing "F10")?


Note:When I replace RibbonWindow with a normal Window, everything works fine.


Title="Window1" Height="600" Width="596" PreviewKeyDown="RibbonWindow_PreviewKeyDown">

PreviewKeyDown="ribbonMain_PreviewKeyDown" KeyDown="ribbonMain_KeyDown" >

Replied On December 16, 2010 03:56 PM UTC

More Info:

When pressing F10, most of the keyboards are disable, and pressing "Alt" has the same behavior as pressing "F10".


Sakthi Kumar A [Syncfusion]
Replied On December 21, 2010 01:29 PM UTC

Hi Kim,

We have analyzed your requirement with your sample code provided by you. In the Ribbon window, functional Keypress is working fine. The information about the telnet communication is not provided in the sample code. Please provide more information about telnet you are using it will be very helpful to us for providing the solution at the earliest.

Please let us know if you have any queries.


Replied On December 21, 2010 02:45 PM UTC

Hi Sakthi!

I don't know that you are responding to this thread or responding to the Incident ID: 75427.

I did attach the stand alone application where there was no Telnet at all (only a Ribbon and a TextBox). The problem is not the Telnet, the problem is the Ribbon)

Steps to reproduce the problem:

1)Run the application.(which I attach to this post)
2)Enter some text in to the textBox
3)Press "F10" (ONLY ONE because it acts like toggle button press One time: Disable, press second time: it enables button)
4)Click back to the text Box.
5)Enter some text ==> most of the key strokes are disabled

The application I attach with this post is the application that I provided you (the Incident ID: 75426)

I will also post this message to the Incident ID: 75426 too.



Sakthi Kumar A [Syncfusion]
Replied On December 22, 2010 06:38 AM UTC

Hi Kim,

We have fixed the functional key disable issue in the latest release version

Please upgrade the Essential Studio and use our RibbonWindow Control.

You can download the latest version from the following location,


Please let us know if you face any issues in the new version.



This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Please sign in to access our forum

This page will automatically be redirected to the sign-in page in 10 seconds.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon