We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Mail Merge for Word 2010

Thread ID:

Created:

Updated:

Platform:

Replies:

97211 Nov 8,2010 02:09 PM Nov 10,2010 07:20 AM ASP.NET Web Forms (Classic) 3
loading
Tags: DocIO
Trinh Beam
Asked On November 8, 2010 02:09 PM

Hi All,

I've problem to generate 'mail merge' Word files on my laptop which is running Winsodws 7 64-bit and Office 2010.

There are no abort or error messages.

I used Syncfusion version 8.3.0.21 and rebuilt my VS 2008 solution but no 'merged' file is created.

Note that my application ran fine with Syncfusion verion 7.2.0.37 on windows 7 32-bit with Office 2007.

Please advise...
Thank you,
Trinh Beam


Poornima R [Syncfusion]
Replied On November 9, 2010 01:51 AM

Hi Trinh,

Thank you for your interest in Syncfusion products.

We are not able to reproduce the mentioned issue. We have created simple mailmerge sample for your understanding. Could you please find the sample from the below link. Try running the sample and let us know if this helps. If the issue still exist, could you please provide us with the sample you are trying to reproduce this issue. So that we can analyze the exact cause of the issue and provide you with clear details.

Sample:
F97211-1357943864.zip


Please let us know if you have any questions.

Regards,
poornima


Trinh Beam
Replied On November 9, 2010 01:46 PM

Poornima,

I ran the sample VS2008 solution to generate a Word file and the Word file open up and there is a "Protected View" error message. Please see the screen shot in the MailMergeIssues.docx in the attached Zip file. "First Try" block uses DataReader and "Second Try" block uses Table for merging data fields.

Other zipped files are templates, output and my codes.

I've tried with version 8.4.0.10 and now try to go back to version 7.2.0.37.

Do I need to setup some options in Word 2010 to make this works?
I've tried to "enable all macros in Word Trust Center - Macro Settings and that didn't help.

Please help!

Thank you,
Trinh Beam



Trinh_b9af5c39.zip

Poornima R [Syncfusion]
Replied On November 10, 2010 07:20 AM

Hi Trinh,

Thank you for your update.

Regarding the "Protected view" issue, this is due to file validation fails in Word 2010. This will not harm the system. Currently we have lagged this as feature request. The feature implementation would also greatly depend on the factors like product design, code compatibility and complexity. We do not have any immediate plan to implement this feature.

Please let us know if you have any questions.

Regards,
Poornima



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;