We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

How to show the Header automatically without click the "Double click to show white space"

Thread ID:

Created:

Updated:

Platform:

Replies:

96116 Aug 23,2010 09:30 AM UTC Sep 8,2010 12:04 PM UTC ASP.NET Web Forms (Classic) 7
loading
Tags: DocIO
Mallikeswaran M.V
Asked On August 23, 2010 09:30 AM UTC

Hi,

I could able to add the Header into the existing word file,
But after that, I cant able to viwe same when I open the word,
I need to click the top of the page "Double click to show white space", then it shows the header, How could avoid these click, or how to show the Header automatically when open the word file.

Please Advice.

Thanks & Regards
G.kalyanasundaram



word header_7716c9c6.zip

Poornima R [Syncfusion]
Replied On August 24, 2010 07:15 AM UTC

Hi kalyanasundaram,

Thank you for your interest in Syncfusion Products.

Generally when adding some text to the header of the already existing document, the header information are visible but disabled from editing when opening the document. This is the actual behavior of MS Word. To edit the header information we need to double click the header part and edit the header text. We have prepared the sample for your requirement. We have also prepared screen video to illustrate this behavior. Could you please find the sample and video from the below link. Try running the sample and let us know if this helps.

Sample link:
http://www.syncfusion.com/uploads/redirect.aspx?&team=support&file=F96116-1024052423.zip


Video link:
http://www.syncfusion.com/uploads/redirect.aspx?&team=support&file=AddingHeader-100866235.zip


Please let us know if you have any questions.

Regards,
Poornima

Mallikeswaran M.V
Replied On August 24, 2010 07:51 AM UTC

Hi Poornima,

I understand your code and video, afraid I am, explained here, when, by code, I have added the header, it works, when opened the word, header not visible unless until the double click to show the white space. regarding this I have attached the video, please find the same.

Please advice.

Thanks & Regards
G.kalyanasundaram




Regarding Header_ce80d520.zip

Poornima R [Syncfusion]
Replied On August 25, 2010 05:46 AM UTC

Hi Kalyanasundaram,

Thank you for your update.

Could you please provide us with the sample you are trying to reproduce this issue. So that we can analyze the cause of the issue and provide you with clear details. Also please provide us with the information about the version of dll you are using to reproduce the issue.

Please let us know if you have any questions.

Regards,
Poornima

Mallikeswaran M.V
Replied On August 25, 2010 06:50 AM UTC

Hi Poornima,

Version details Follows:

Product: Essential DocIO [Windows Forms]
Product Version: 8.3.0.21
.NET Framework Version: .NET Framework Version 2.0
Operating System Information: Windows XP
Bit Information: 32 Bit
MS Office Version: MS Office Version 2007
Preferred Programming Language: C#

Also I have attached the word documet currently I am working on.

Just open the word, you could not see any header on that,

As per video, just do the "Double click to show white space", then see, the header will show.

Please Advice.

Thanks & Regards
G.kalyanasundaram



1767-87-17-111-Test_658dbf25.zip

Poornima R [Syncfusion]
Replied On August 26, 2010 06:43 AM UTC

Hi kalyanasundaram,

Thank you for your update.

We have analyzed the document provided by you. The problem exist in the document level. When viewing the document in package explorer you can see tag was internally set in the document. This tag causes the header to be disabled. When this tag is removed from the document, header displays correctly. We have prepared the screen video to illustrate this behavior. Could you please find the screen video from the below link. Try viewing the video and let us know if this help. Could you please provide us with the sample how the provided input document is created. So that we can find the exact cause of the issue and provide you with the solution.

Screen video:
http://www.syncfusion.com/uploads/redirect.aspx?&team=support&file=HeaderDisplay-313086066.zip

Please let us know if you have any questions.

Regards,
Poornima

Mallikeswaran M.V
Replied On September 7, 2010 09:36 AM UTC

Hi Poornima R,

apologies for the delayed response.

I understand the video, how do i implement that using docio.

The word file generated from dynamic form, by default file is html, while in operation,on the fly,those were converted into word file. so the file may be doc or docx file.

please advice.

Thanks & Regards
G.kalyanasundaram


Poornima R [Syncfusion]
Replied On September 8, 2010 12:04 PM UTC

Hi Kalyanasundaram,

Thank you for your update.

Currently DocIO handles "DoNotDisplayPageBoundaries" property internally. We have considered the feature of adding "DoNotDisplayPageBoundaries" property as a public property to handle the documents explicitly. We have logged the feature request for the same. Since the problem occurs within the document level, could you please provide us with the sample you are trying to create the provided input document. So that we can analyze the cause of the issue and provide you with clear details.


Please let us know if you have any questions.

Regards,
Poornima


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;