We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

line bridging

Thread ID:

Created:

Updated:

Platform:

Replies:

95684 Jul 24,2010 09:28 AM Jul 28,2010 02:01 AM Windows Forms 5
loading
Tags: Diagram
Administrator [Syncfusion]
Asked On July 24, 2010 09:28 AM

I am using a diagram with its measurement units set to inches so that the rulers show in inches. However, I don't know how to adjust the setting to make the line bridging appear normal. Right now the bridging arcs don't seem to appear at all. (I have line bridging enabled and it works find if I set the measurement units to pixels.) I probably have the arc size set to the wrong value but nothing I try seems to work. Can anyone steer me in the right direction?

v/r
Jan

Varalakshmi R.S [Syncfusion]
Replied On July 26, 2010 08:59 AM

Hi Jan,

I'm afraid that i am not able to reproduce the issue that you posted. I have created the sample which creates the diagram with it’s measurement units set to inches and BridgeStyle as Arc. But still the arcs are visible in the sample which I tried to reproduce.

I have attached the sample that demonstrates this completely.

line bridge2046885745.zip

Please refer to the sample and let me know if you have any questions.

Best regards,
Varalakshmi.R.S

Administrator [Syncfusion]
Replied On July 26, 2010 11:28 AM

Your example shows the rulers in 'Pixels'. I want to show the rulers in 'Inches'. Your example doesn't have any crossing links so line bridging doesn't come into play. I need to have a diagram which uses inch units with line bridging supported. Maybe I described the problem poorly.

Varalakshmi R.S [Syncfusion]
Replied On July 27, 2010 04:51 AM

Hi Jan,

Thanks for the update.

The issue "Line Brdiging- arcs are not visible in Inch-Measurement unit" reported by you is suspected to be a defect. We have forwarded this to our Developement team for further analysis. We will update you with our Development team's reponse in two business days.

Regards,
Varalakshmi.R.S

Administrator [Syncfusion]
Replied On July 27, 2010 08:09 AM

Thank you for the info. I will check back in a couple of days. If you have a work around for this problem, I would appreciate an small example.

v/r
Jan

Varalakshmi R.S [Syncfusion]
Replied On July 28, 2010 02:01 AM

Hi Jan,

Thank you for being patience.

"Line Brdiging- arcs are not visible in Inch-Measurement unit" issue can be solved by changing all the symbols, Model and ConnectionPoints measurement unit to “Inches” and enable the “LineBridgingEnabled” property of the “model”. If it’s not enabled then arc will not be visible.

I have attached the sample that demonstrates this completely.

LineBridging1-142181568.zip

Please try the sample and let me know if you have any questions.

Regards,
Varalakshmi.R.S

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;