We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Keep getting memory exception from VS2008

Thread ID:

Created:

Updated:

Platform:

Replies:

95626 Jul 21,2010 06:26 PM Jul 26,2010 01:10 AM General Discussion 3
loading
Tags: General Discussion
Youfei Chen
Asked On July 21, 2010 06:26 PM

Hi, I'm using a lot of syncfusion controls in my project, but when the project is growing, I'm getting more and more memory exceptions from VS2008, especially after when I'm trying to compile my project after modifying control's layout.

The problem is gone if I re-launch the VS, but will return some time later.

I dont think I really run out of my memory, so can you give me some help?

Please see attachment for screen shots



sf_638441bc.zip

Velusamy Subramaniam [Syncfusion]
Replied On July 22, 2010 08:36 AM

Hi Youfei,

Thanks for using our Syncfusion products.

There is apparently a hard limit of memory per process in windows of 2 GB. And between everything else that was going on in visual studio and our compression process, we were just barely crossing this threshold. The following resolution solved our problem by increasing the limit to 3 GB.

1) Backup the boot.ini file. Then, put the /3GB switch in your boot.ini For more information on the /3GB option,

2) please check the following article: Memory Support and Windows Operating Systems: http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx

3) Make DEVENV large address aware.

4) Open up a VS 2008 command prompt

5) Change directory to the Microsoft Visual Studio 9\Common7\IDE directory.

6) Backup devenv.exe file.

7) Type and execute the following command line: "editbin /LARGEADDRESSAWARE devenv.exe"

8) Reboot Windows and Build your project.

Please let me know if this helps you.

Thanks,
Velusamy

Youfei Chen
Replied On July 23, 2010 11:08 AM

It works great so far, Thanks!!

Velusamy Subramaniam [Syncfusion]
Replied On July 26, 2010 01:10 AM

Hi Youfei,

Thanks for the update and we are glad that your issue is resolved.

Please get back to us if you have any other concerns.

Regards,
Velusamy

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;