We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Slow scrolling with a RDP connection

Thread ID:

Created:

Updated:

Platform:

Replies:

95597 Jul 20,2010 11:45 AM Aug 11,2010 05:39 AM Windows Forms 8
loading
Tags: EditControl
Alexander De Man
Asked On July 20, 2010 11:45 AM

Hi,

We use an EditControl in our application and it's often used with a RDP connection. This works good except for the scrolling. It's very slow because of the 'animations'. Is there some way to disable the animations (could't find anything myself)? Maybe some built in feature by checking the SystemInformation.TerminalServerSession value.

Thanks

Ramya D [Syncfusion]
Replied On July 21, 2010 06:39 AM

Hi Alexander,

Thanks for your interest in Syncfusion products.

If you are meaning about the autoscrolling behavior of the EditControl, you can disable it by setting AutoScroll property to false.

this.editControl1.AutoScroll = false;

Could you please provide us with the screenshots so that we can analyse the behavior in depth and can provide a better solution.
Please let us know if we have misunderstood your query.

Regards
Ramya D.

Alexander De Man
Replied On July 28, 2010 05:37 AM

Sorry for my late reply. Let me explain it some more:

When scrolling with the scroll wheel on the mouse, the script moves up or down on the screen. This movement is smoothed by the scriptcontrol, so the text will gradually move up or down instead of the whole line at an instant. While looking really cool, this is actually quite a hindrance in situations where lots of screenupdating significantly slows down the computer, like with a Remote Desktop Connection (RDP). For example: Scrolling a full-screen scriptcontrol on a RDP window (1920x1200 pixels) may take several seconds to scroll just a few lines of text. Smaller windows will increase speed, but the delay is still significant.

We need to disable the gradual scrolling. Preferably just when using a RDP connection, otherwise disable it completely. How can we accomplish this?

Lokanath E [Syncfusion]
Replied On August 3, 2010 02:29 AM

Hi Alexander,

We regret for the delay in getting back to you,

The scrolling in EditControl can be disabled by setting the ShowHorizontalScrollers and ShowVerticalScrollers property to false.
This will allow key board navigation.

this.editControl1.ShowHorizontalScroller = false;
this.editControl1.ShowVerticalScroller = false;

Please let us know if this helps.

Regards,
Lokanath.E

Alexander De Man
Replied On August 3, 2010 11:07 AM

I have the feeling there's a misunderstanding about the issue. The problem is performance, not a presence of a scrollbar. To illustrate the problem, I've uploaded a video which demonstrates the delay that occurs when scrolling. It's semi-clearly visible, that the text is still scrolling a while after the scrollwheel stops moving.

Please note, this delay ONLY occurs during a Remote Desktop Connection. On a regular desktop PC there's no delay.

We think the cause of this delay is the animation/smoothing of scrolling. This causes many screenupdates which simply is not suited for a RDP connection. So lowering the updates (thus disabling the animation) should fix the problem. We just need to know how to do this, if at all possible.

http://www.youtube.com/watch?v=g-ZyWjIDGBo

Vallarasu S [Syncfusion]
Replied On August 6, 2010 05:26 AM

Hi Alexander,

Thanks for the update,

You can disable mouse wheel scrolling on EditControl by implementing IMessageFilter in the form as follows,


public class Form1 : System.Windows.Forms.Form, IMessageFilter
...
public bool PreFilterMessage(ref Message m)
{
//You can have your conditions here like if(onRDP)
if (m.Msg == 0x020A /*WM_MOUSEWHEEL*/ && this.ActiveControl is EditControl)
return true;
return false;
}


Refer the sample that demonstrates the above.

Please let us know if you have concerns on this.

Regards
Vallarasu S.



EditSample_1577c675.zip

Alexander De Man
Replied On August 6, 2010 06:39 AM

I don’t mean disrespect, but am I really that hard to understand?

We don’t want to disable the scrollwheel
We don’t want to disable the scrollbars
We don’t want to disable text that is higher as a window
We don’t want to wait several seconds for a scrollwheel action to finish

We DO need to be able to show a lot of text with all the default features for scrolling enabled. We just need more performance when using a Remote Desktop Connection.

A regular memobox works perfectly on a Remote Desktop Connection. Even application like Microsoft Office Word work fast. It’s just Essential Edit which seems to be really slow.

Please?!

Vallarasu S [Syncfusion]
Replied On August 11, 2010 05:28 AM

Hi Alexander,

We regret for the delay in getting back to you,

Could you please raise this query in our Direct Track Support at the following link,

http://www.syncfusion.com/support/DirectTrac/

We will follow up this query for possible performance improvements there,

Please let us know if you have concerns on this,

Regards
Vallarasu s.

Vallarasu S [Syncfusion]
Replied On August 11, 2010 05:39 AM

Hi Alexander,

Please ignore the link in previous update and use the following link to raise an incident,

http://www.syncfusion.com/support/directtrac

Thanks for using Syncfusion products,

Regards
Vallarasu S.

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;