We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Problem with Deployment

Thread ID:

Created:

Updated:

Platform:

Replies:

94281 May 4,2010 09:00 AM UTC Jul 6,2010 12:46 PM UTC General Discussion 7
loading
Tags: General Discussion
Vahid
Asked On May 4, 2010 09:00 AM UTC

Dear Sir
I developed a windows application project (Visual Studio2008) and I used Syncfusion component to make XLS files. Now, I want to deploy this project to other systems.
This project debugs and builds successfully in my system, but it doesn’t work elsewhere.
I try different ways to overcome this problem.
First: Make a release of project and move it to another system but faced with this problem:
Could not load file or assembly 'Syncfusion.XlsIO.Base, Version=7.203.0.37, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' or one of its dependencies. The system cannot find the file specified.

Second: Make Publish of my project, but when I run Application Manifest this message is appeared:
Unable to install or run the application. The application requires that assembly syncfusion. Compression.base version 7.203.0.37 be installed in the GAC first.
I installed my pc assemble (syncfusion) manually at destination pc but it doesn’t work!!

Third: I make a setup project and add, Syncfusion.Core.dll, Syncfusion.XlsIO.Base.dll, Syncfusion.XlsIO.windows.dll, Syncfusion.Compression.Base.dll to Global Assembly Cache folder, but when I run the setup it say the same thing as publish.

Note: I make folder in my project and copy DLLs from
Syncfusion\Essential Studio\7.2.0.37\Assemblies\3.5
To that folder then I add it to Project References.

Regards
Vahid

Velusamy Subramaniam [Syncfusion]
Replied On May 4, 2010 10:48 AM UTC

Hi Vahid

Thanks for using our Syncfusion products.

Please make sure the following things in your project.

1) If you set the CopyLocal=False for all the Syncfusion assemblies in your project. Then, you have to deploy the Syncfusion assemblies into the GAC in your deployment machine.

2)If you set the CopyLocal=True for all the Syncfusion assemblies in your project. Then, you have to place the Syncfusion assemblies in the output folder in your deployment machine.

Please let me know if this helps you.

Regards,
Velusamy

Vahid
Replied On May 4, 2010 05:13 PM UTC

Thank you for reply Velusamy

How could i check CopyLocal parameter ? I think it's related to third way that i used.

I think my problem refers to adding license to deployed project, because Syncfusion.Core.dll, Syncfusion.XlsIO.Base.dll, Syncfusion.XlsIO.windows.dll have to transfered to destination system and install to assemblies with its publickeytoken but i don't know the write way.

regards

Velusamy Subramaniam [Syncfusion]
Replied On May 5, 2010 09:01 AM UTC

Hi Vahid,

You can check the CopyLocal parameter by clicking on corresponding assemblies from the reference in solution explorer of your project and select the properties window.

Could not load assemblies error occur because of Syncfusion assemblies is not there in either GAC (if you set the Assembly Reference as CopyLocal=False) or in Bin or local folder where you referred from(If you set the Assembly Reference as CopyLocal=True). Please make sure this and re-compile your project in your development machine.

Now deploy your application in your deployment machine and place required assemblies into the GAC if you set the CopyLocal=true in your project.

If you still face the issue, please provide more information about the issue and send me the sample with corresponding assemblies. Please let me know if you have any queries.

Regards,
Velusamy

Vahid
Replied On May 8, 2010 05:11 PM UTC

Thank you very much velsummy!! it solves my problem.

Regard,
Vahid

Velusamy Subramaniam [Syncfusion]
Replied On May 10, 2010 05:03 AM UTC

Hi Vahid,

Thanks for the update and we are glad that your issue is resolved.

Also, get back to us if you have any other concerns.

Regards,
Velusamy

Administrator [Syncfusion]
Replied On July 5, 2010 12:41 PM UTC

Please could you clarify the following? Comments in these 2 posts seem to be contradicting each other:

Velusamy S[Syncfusion] at 5/4/2010 6:48:06 AM
1) If you set the CopyLocal=False for all the Syncfusion assemblies in your project. Then, you have to deploy the Syncfusion assemblies into the GAC in your deployment machine.

2)If you set the CopyLocal=True for all the Syncfusion assemblies in your project. Then, you have to place the Syncfusion assemblies in the output folder in your deployment machine.


Velusamy S[Syncfusion] at 5/5/2010 5:01:35 AM
Could not load assemblies error occur because of Syncfusion assemblies is not there in either GAC (if you set the Assembly Reference as CopyLocal=False) or in Bin or local folder where you referred from(If you set the Assembly Reference as CopyLocal=True). Please make sure this and re-compile your project in your development machine.

Now deploy your application in your deployment machine and place required assemblies into the GAC if you set the CopyLocal=true in your project.



Velusamy Subramaniam [Syncfusion]
Replied On July 6, 2010 12:46 PM UTC

Hi Paul,

We deeply regret for the inconvenience caused.

I have modified my updates. Please find the same below

Velusamy S[Syncfusion] at 5/4/2010 6:48:06 AM

1) If you set the CopyLocal=False for all the Syncfusion assemblies in your project. Then, you have to deploy the Syncfusion assemblies into the GAC in your deployment machine.

2)If you set the CopyLocal=True for all the Syncfusion assemblies in your project. Then, you have to place the Syncfusion assemblies in the Bin/local folder in your deployment machine.


Velusamy S[Syncfusion] at 5/5/2010 5:01:35 AM

Could not load assemblies error occur because of Syncfusion assemblies is not there in either GAC (if you set the Assembly Reference as CopyLocal=False) or in Bin/local folder where you referred from(If you set the Assembly Reference as CopyLocal=True). Please make sure this and re-compile your project in your development machine.

Now deploy your application in your deployment machine and place required assemblies into the GAC if you set the CopyLocal=false in your project.

Please let me know if you have any concerns.

Thanks,
Velusamy

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;