We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

How to disable pasting after paste is called once

Thread ID:

Created:

Updated:

Platform:

Replies:

93922 Apr 12,2010 11:00 AM Apr 12,2010 11:15 AM Windows Forms 2
loading
Tags: GridControl
Andrew Lien
Asked On April 12, 2010 11:00 AM

I am using GDBG and when I select text from one cell and paste (using Ctrl+V)into another cell, paste is called twice and I get two instances of what was in the clipboard pasted into the cell, e.g. if I copy the text "A" from one cell I will get "AA" when I paste.
I am wondering if there is a way to prevent this from happening and only to paste once. I know there are events to handle copy and paste, but I don't want to mess with what is in the clipboard. I just want to disable pasting after I paste once, such as using a flag to control this behavior.

Thanks.

Andrew Lien
Replied On April 12, 2010 11:14 AM

OK, I saw that there was a fix listed on the forum here that I didn't see before:

http://www.syncfusion.com/support/forums/grid-windows/93467/Pasting-issue-with-Grid-Windows-in-2010-Vol-1-version-(81030)

Installed the patch and it works fine now.

Thanks.

Rajadurai C [Syncfusion]
Replied On April 12, 2010 11:15 AM

Hi Andrew,

Thanks for your update.

Regards,
Rajadurai

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;