We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

DesiredHeightIn has no effect

Thread ID:

Created:

Updated:

Platform:

Replies:

88344 Jul 20,2009 09:22 AM Jul 29,2009 09:12 AM WPF 3
loading
Tags: Tools
Robert Koelz
Asked On July 20, 2009 09:22 AM

Hello,

i tried out the docking manager and wanted to start with a control which has the state FLOAT at the beginning. Therefore i set the DesiredHeight/Width properties for the entire control. But the control starts not sized as defined!!! Its alway in top left corner with a dimension of ca. 100x80. Whats going wrong?

UseDocumentContainer="False" DockFill="True">




Prabhu P [Syncfusion]
Replied On July 22, 2009 01:27 AM

Hi Rob,

Thank you for your interest in Syncfusion products.

You can make use of the SetFloatingWindowRect(…) method to set the height and width of the floating windows. Kindly make use of the code snippet for more idea.

DockingManager.SetFloatingWindowRect(floatwindow, new Rect(new Point(100, 150), new Size(300, 300)));

Currently the attached property, DesiredWidthInFloatingMode and DesiredHeightInFloatingMode are not bound with the SetFloatingWindowRect method. In our future release we will resolve these binding problems. And we hope that all your requirements can be fulfilled with the SetFloatingWindowRect method itself.

Please let me know if you have any difficulties.

Regards,
Prabu

Robert Koelz
Replied On July 23, 2009 10:06 AM

ok this solution works fine for the startup settings

but how about docking this floating window? Therefore i used the DesiredHeightInDockedMode property, but it seems that it isn't bound to any sizing mechanism, too. It always uses 50% of the available space if there is already one other control in the docking area. The existing control should always be primary element and that i dock into should have a height of max. 200px.

Prabhu P [Syncfusion]
Replied On July 29, 2009 09:12 AM

Hi Robert,

Thanks for the details. We suspect that you might set “DockFill” property as true in your application. This makes your dock window to fill in the application. If your application has only two Dock window elements then both Dock window elements will occupy 50% of space each.

If you still have a problem, please update us with your sample. So that we can investigate the problem in your sample and provide the possible solution.

Regards,
Prabu

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;