We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Tools on legends

Thread ID:

Created:

Updated:

Platform:

Replies:

80281 Mar 26,2009 02:09 PM UTC Mar 31,2009 06:48 AM UTC WPF 5
loading
Tags: Chart
Lionel Thiebaut
Asked On March 26, 2009 02:09 PM UTC

Hi,
I'd like to know how to disable the legends tools which appear after a double click on it.
Thanks.
Lionel


Administrator [Syncfusion]
Replied On March 27, 2009 09:36 AM UTC

Hi Lionel,

Thanks for your interest in Syncfusion products.

By legend tools I hope you mean the "Chart Legend Properties" window that appears on double click.

If so, you could handle the legends PreviewMouseDoubleClick event and disable the Legend Properties window.

[XAML]
PreviewMouseDoubleClick="ChartLegend_PreviewMouseDoubleClick" />

[C#]
private void ChartLegend_PreviewMouseDoubleClick(object sender, MouseButtonEventArgs e)
{
e.Handled = true;
}

Please let me know if I have misunderstood your query.

Regards,
K. Saradha Devi




Lionel Thiebaut
Replied On March 30, 2009 08:47 AM UTC

Hi,
It is not good, I don't have the Property.
And when I do this in the code behind, the problem is always here.
I'm in version 6.4.0.15
Thank you.
Lionel


>Hi Lionel,

Thanks for your interest in Syncfusion products.

By legend tools I hope you mean the "Chart Legend Properties" window that appears on double click.

If so, you could handle the legends PreviewMouseDoubleClick event and disable the Legend Properties window.

[XAML]
PreviewMouseDoubleClick="ChartLegend_PreviewMouseDoubleClick" />

[C#]
private void ChartLegend_PreviewMouseDoubleClick(object sender, MouseButtonEventArgs e)
{
e.Handled = true;
}

Please let me know if I have misunderstood your query.

Regards,
K. Saradha Devi







Lionel Thiebaut
Replied On March 30, 2009 11:27 AM UTC

I found the property but the problem is always here. Do you have an another idea to disable that ?
Thank you


Lionel Thiebaut
Replied On March 30, 2009 11:31 AM UTC

I'm sorry I manage to disable it but It's a shame that you don't put a property to disable that. It will be more easy with that.
Thank you for your answer.



Pavithra J [Syncfusion]
Replied On March 31, 2009 06:48 AM UTC

Hi Lionel,

Thanks for your suggestion. We will consider this and make it as a feature request.

Thank you for your interest in Syncfusion products.

Regards,
Pavitha.J


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;