We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Legend Properties dialog

Thread ID:

Created:

Updated:

Platform:

Replies:

80184 Mar 18,2009 08:47 PM UTC Jul 1,2009 01:11 PM UTC WinForms 5
loading
Tags: Chart
Administrator [Syncfusion]
Asked On March 18, 2009 08:47 PM UTC

Hello,

When a user double clicks on the legend on of my charts, the Legend Properties dialog is displayed. Is there any way to prevent this?

I thought that setting AllowUserEditStyles = false would do it, but it doesn't seem to be the case.

Thanks


Manimala S [Syncfusion]
Replied On March 19, 2009 02:09 PM UTC

Hi Michael,

I will look for a way and will let you know once I have got this.

Thanks,
Manimala.


Manimala S [Syncfusion]
Replied On March 20, 2009 04:18 AM UTC

Hi Michael,

To disable the legend properties dialog box just include the line below in the form_load() event.


this.chartControl1.Legend.Enabled = false;

Kindly, let me know if it helps.

Thanks,
Manimala.


Paul Wallace
Replied On June 25, 2009 01:04 PM UTC

How can you suppress the properties dialog from appearing if you have enabled checkboxes to hide/show individual series?

Disabling the legend disables the checkboxes.

Paul

Manimala S [Syncfusion]
Replied On June 26, 2009 05:25 AM UTC

Hi Paul,

We can set the legend style property to Empty, so as to suppress the properties dialog box. Here is the code snippet to do this.

//Code

'To Disable the Legend property edit window and series style edit window
ChartControl1.Legend.VisibleCheckBox = True
'To Disable series style edit window alone.
ChartControl1.Legend.Style = ChartLegendStyle.SupportEditProperties
'To Disable Legend property edit window alone.
ChartControl1.Legend.Style = ChartLegendStyle.SupportItemStyleEdit


Kindly let me know if it helps.

Thanks,
Manimala.

Paul Wallace
Replied On July 1, 2009 01:11 PM UTC

Yes, that works.

Thanks

CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;