We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Syncfusion still doesn''t install properly on x64 machines

Thread ID:

Created:

Updated:

Platform:

Replies:

79695 Feb 21,2009 12:08 AM UTC Feb 26,2009 06:09 PM UTC General Discussion 8
loading
Tags: General Discussion
Keith Steinbeck
Asked On February 21, 2009 12:08 AM UTC

So,

I installed ES 2009 Vol. 1 on a fresh Win7 (x64) machine and the install completed without any errors. However no samples would compile because the sample browser couldn't resolve any of the Syncfusion references.

I turns out that no assemblies were copied into the GAC. It turns out that this isn't a new problem:

http://www.syncfusion.com/support/forums/message.aspx?MessageID=70287

Adding the assemblies by hand seems to have fixed this however. Maybe it was a combination of x64 and Win7; regardless this should be looked into.




Administrator [Syncfusion]
Replied On February 21, 2009 02:33 PM UTC

Ok, then I am not the only one having problems here.. I have a fresh instal of Vista 64 with SP1 and all patches, and Visual Studio loaded (all patches). I know it is not my system as I have a 965 i7 processor, 12 gigs of ram and a Raid 0 with SSD Intel drives on an Adaptec 5805 card so the hardware is MORE than fast enough...

My maintenence is coming up for this product and I really have some reservations on paying it because we have had issues with it since day one and things still are not fixed. When something is fixed, something else seems to break.



Administrator [Syncfusion]
Replied On February 23, 2009 07:32 AM UTC



>Ok, then I am not the only one having problems here.. I have a fresh instal of Vista 64 with SP1 and all patches, and Visual Studio loaded (all patches). I know it is not my system as I have a 965 i7 processor, 12 gigs of ram and a Raid 0 with SSD Intel drives on an Adaptec 5805 card so the hardware is MORE than fast enough...

My maintenence is coming up for this product and I really have some reservations on paying it because we have had issues with it since day one and things still are not fixed. When something is fixed, something else seems to break.




Hi Binary,

We regret for the inconvenience caused.

Could you please let us know the Visual Studio versions installed in your machine and let us know if you have the following entries in your registry. We check for these registry entries in order to install the assemblies in GAC.

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework", "sdkInstallRootv2.0"

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0A\WinSDKNetFxTools"

If you don't have it in your machine, please let us know which SDK is installed in the machine.

Regards,
Ramani


Ramani S [Syncfusion]
Replied On February 23, 2009 07:34 AM UTC

Hi Binary,

We regret for the inconvenience caused.

Could you please let us know the Visual Studio versions installed in your machine and let us know if you have the following entries in your registry. We check for these registry entries in order to install the assemblies in GAC.

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework", "sdkInstallRootv2.0"

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0A\WinSDKNetFxTools"

If you don't have it in your machine, please let us know which SDK is installed in the machine.

Regards,
Ramani


Administrator [Syncfusion]
Replied On February 23, 2009 01:32 PM UTC

I don't see the first one, but for the second I show.
ProductVersion: v6.0A


>Hi Binary,

We regret for the inconvenience caused.

Could you please let us know the Visual Studio versions installed in your machine and let us know if you have the following entries in your registry. We check for these registry entries in order to install the assemblies in GAC.

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework", "sdkInstallRootv2.0"

"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.0A\WinSDKNetFxTools"

If you don't have it in your machine, please let us know which SDK is installed in the machine.

Regards,
Ramani




Keith Steinbeck
Replied On February 23, 2009 08:00 PM UTC

In my case (Windows 7 x64) I have neither of the locations you suggest.

Instead I have:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft.NETFramework.NETFramework/, with
AssemblyFolders
NGenQueue
Policy
Security
v2.0.50727
v3.0
Windows Presentation Foundation

and

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v6.1\, with
WinSDK
WinSDKBuild
WinSDKDocWin32
WinSDKMDAC
WinSDKSamples
WinSDKTools
WinSDKWin32Tools

It seems pretty clear that the syncfusion installer is looking for registry values that just don't exist on x64 machines, in addition to other issues (SDK versions for example) on Windows 7 machines.

I hope this info helps solve these problems. If you need more info let me know.





Ramani S [Syncfusion]
Replied On February 24, 2009 01:28 AM UTC

Hi Keith,

Our installation checks for the registry key that i have mentioned in my previous update. Id it is not there then the assemblies will not be installed in GAC. To solve this issue please install the VS 2008 SDK. We will fix these issues in our next release. Till then could you please install the VS 2008 SDK and proceed.

Thank you for your patience.

Regards,
Ramani


Keith Steinbeck
Replied On February 24, 2009 04:42 PM UTC

Ramani,

Thanks for the info; I'll post back if I have any additional problems.

Keith

>Hi Keith,

Our installation checks for the registry key that i have mentioned in my previous update. Id it is not there then the assemblies will not be installed in GAC. To solve this issue please install the VS 2008 SDK. We will fix these issues in our next release. Till then could you please install the VS 2008 SDK and proceed.

Thank you for your patience.

Regards,
Ramani




Ramani S [Syncfusion]
Replied On February 26, 2009 06:09 PM UTC



>Ramani,

Thanks for the info; I'll post back if I have any additional problems.

Keith

>Hi Keith,

Our installation checks for the registry key that i have mentioned in my previous update. Id it is not there then the assemblies will not be installed in GAC. To solve this issue please install the VS 2008 SDK. We will fix these issues in our next release. Till then could you please install the VS 2008 SDK and proceed.

Thank you for your patience.

Regards,
Ramani





Hi Keith,

Sure, Thank you. Let us know if you have any further queries.

Regards,
Ramani


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;