We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

Changing a property on my custom symbol doesn''t set the diagram''s modified flag

Thread ID:

Created:

Updated:

Platform:

Replies:

79356 Feb 3,2009 11:24 AM Feb 6,2009 12:58 PM Windows Forms 3
loading
Tags: Diagram
Ron Alan Sawyer
Asked On February 3, 2009 11:24 AM

On my diagrams I am using symbols that have been derived from Group. For some reason setting a property on them does not change the diagram's modified flag. Have I forgotten to implement something in the symbol? Or, alternately, how do I force the modified flag to be set to true when a property is set?


Ajeet M [Syncfusion]
Replied On February 5, 2009 07:09 AM

Hi RAS,

I am afraid but I was able to detect the property change on a symbol derived from the Group Class.

The attached sample demonstrates the same.

Let me know if you shall need any further clarifications in this regard.

Happy coding!
- Ajeet




Diagram_WF_PropertyChange_c28478d3.zip

Ron Alan Sawyer
Replied On February 5, 2009 09:37 AM

Thank you for the response. I have entered a Direct-Trac issue.


Ron Alan Sawyer
Replied On February 6, 2009 12:58 PM

My apologies. I misread your response. I am currently using an older version of Syncfusion until a bug is fixed in the current version. It should be fixed on the 13th. Perhaps that will fix my issues.


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;