We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

visual studio 2008 and Essential Studio 2008 vol 2.

Thread ID:

Created:

Updated:

Platform:

Replies:

75516 Jul 29,2008 07:58 AM Jul 31,2008 05:13 AM General Discussion 6
loading
Tags: General Discussion
Joel Descombes
Asked On July 29, 2008 07:58 AM

I installed the Essential Studio 2008 vol 2 to use the version 6.3 of the windows forms components. However, I must use the Framework.NET 2.0. I have Visual Studio 2008 and SyncFusion components cannot be used even if I add them manually in the toolbox.
I'm adding version 6.302.x.x of the components. Are they working under .NET 2.0 ? If yes, how to allow VS2008 to enable them ? They all appear desactivated.
Thanks for any help. This is urgent.


Ramani S [Syncfusion]
Replied On July 30, 2008 02:39 AM

Hi Joel,

Sorry for the inconvenience caused.

Could you please let me know the essential studio version that you are using in your machine at present?


Regards,
Ramani


Ramani S [Syncfusion]
Replied On July 30, 2008 02:48 AM

Hi Joel,

Basically, With v6.3.0.6 we ship both .NET framework 2.0 ad .NET framework 3.5 assemblies.

During the installation, we target the .NET framework 2.0 assemblies to VS2005 and .NET framework 3.5 assemblies to vs2008.

Since VS2008 supports multi-targeting. We need to perform the following step before starting devlopment with vs2008 with TargetFramework set to 2.0.

Could you please try the utility attached with this.

In this utility, Please select .NET Framework 2.0 to develop applications and then press the button "Start Action". Once successfully completed please open the IDE.

Also, You need to add syncfusion 2.0 assemblies to the VS toolbox manually.

Please try this and let us know if you need any further information.

Regards,
Ramani



Multi Target Manager_eebd56a1.zip

Joel Descombes
Replied On July 30, 2008 04:43 AM

Hello,

Currently I have the version 2.0.5 of the syncfusion components installed on my machine. This is version is used by the application I have to migrate to .NET 2.0.
Now I installed syncfusion version 6.3 after VS2008.
I found on the forum this utility to select the used framework version. After execution, it just allow me to use syncfusion 3.302 but not 6.302.


>Hi Joel,

Basically, With v6.3.0.6 we ship both .NET framework 2.0 ad .NET framework 3.5 assemblies.

During the installation, we target the .NET framework 2.0 assemblies to VS2005 and .NET framework 3.5 assemblies to vs2008.

Since VS2008 supports multi-targeting. We need to perform the following step before starting devlopment with vs2008 with TargetFramework set to 2.0.

Could you please try the utility attached with this.

In this utility, Please select .NET Framework 2.0 to develop applications and then press the button "Start Action". Once successfully completed please open the IDE.

Also, You need to add syncfusion 2.0 assemblies to the VS toolbox manually.

Please try this and let us know if you need any further information.

Regards,
Ramani



Multi Target Manager_eebd56a1.zip


Ramani S [Syncfusion]
Replied On July 31, 2008 01:32 AM

Hi Joel,

Sorry for the inconvenience caused.

I feel that your GAC has also got the older versions assemblies installed in it.

Could you please follow these steps:

1. Please open 6.3.x.x Assembly Manager from dashboard and choose option remove all versions and click Perform action.

2. Please check whether all the syncfusion assemblies are removed from the below locations.

C:\WINDOWS\assembly
C:\Program Files\Microsoft Visual Studio 8\Common7\IDE\PublicAssemblies
C:\Program Files\Reference Assemblies\Microsoft\Framework\v3.5
C:\Program Files\Common Files\Microsoft Shared\MSEnv\PublicAssemblies

3. Again from the assembly manager choose install version to install the version 6.3.x.x assemblies.

4. Make sure that your machine contains only the 6.3.x.x assemblies in the above given locations.

5. Please run the utility manager which i attached to you in my previous update.

6. While running the utility manager please choose 2.0 framework and click ok once succesfully completed.

7. Open your application and make sure in the properties window whether you references points to version 6.302.X.X

8. Set specific version property to false in the properties window.

9. Compile and run the project.


If you still have problem, please refer this KB link

http://www.syncfusion.com/support/kb/studio/Default.aspx?ToDo=view&questId=60

Please let me know if this helps.

Thanks for your patience.

Regards,
Ramani


Joel Descombes
Replied On July 31, 2008 04:46 AM

Thanks for your help.
Unfortunatly, for compatibility reason with the existing software, I cannot uninstall the old version.
In consequence we have decided to rollback to Visual Studio 2005.


Ramani S [Syncfusion]
Replied On July 31, 2008 05:13 AM

Hi Joel,

I regret for the inconvenience caused.

Please do contact us if you have any further questions.

Regards,
Ramani


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;