We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

AutofitColumn

Thread ID:

Created:

Updated:

Platform:

Replies:

74374 Jun 10,2008 07:31 AM Jul 17,2008 02:52 AM Windows Forms 3
loading
Tags: XlsIO
Administrator [Syncfusion]
Asked On June 10, 2008 07:31 AM

Hi,

I've to autofit a range of cells. There are some cells of the column containing a bigger value, but those should be ignored by auto sizeing.
e.g.
B1: a very long text should be ignored
B2: a short one
B3: a nother short one
...

In my example, I tried to
mySheet.Range[5, 2, 19, 2].AutofitColumns();

I suppose that the component watches on all cells of the column and not only the range (like Excel does). Is there a way to tell xlsIO just to watch the range? Or any other work around?

I'm using version '6.302.0.6' of xlsIO

best regards

Joachim Brust



Program_265b2c9b.zip

Yavanaarasi G [Syncfusion]
Replied On June 11, 2008 08:48 AM

Hi Joachim,

Thank you for your interest in Syncfusion products.

We have already logged a feature request regarding this issue. We will get back to you once the feature has been implemented.

Please let me know if you have any other concerns.

Regards,
G.Yavana


blah blah
Replied On July 16, 2008 11:09 AM

I know you've already logged this as a feature request...

I've been using your Excel classes since 2004 and would love the requested functionality as well. Our Excel reports have a standard header in the first column that takes up a few rows. The report data follows that. It would be great to be able to get AutofitColumns() to ignore those header rows.

I'm aware that I can currently work around this by setting the report data and calling AutofitColumns() before I set the header rows, but that adds much unneeded complexity.


Yavanaarasi G [Syncfusion]
Replied On July 17, 2008 02:52 AM

Hi Joachim,

Thanks for your effort.

Unfortunately this feature is not implemented. This feature implementation will take time and can’t be implemented in short period. But we have increased its priority. We will get back to you once the feature has been implemented. Sorry for the inconvenience caused.

Regards,
G.Yavana


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;