We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on : Nov 16th 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

I need to improve performance of the grids

Thread ID:

Created:

Updated:

Platform:

Replies:

72137 Mar 4,2008 07:28 PM UTC Mar 10,2008 09:39 PM UTC WinForms 1
loading
Tags: GridControl
Paul P
Asked On March 4, 2008 07:28 PM UTC

I am writing an application that receives "live tick data" from an out side source. I have a form that has a bunch of grids that are used to store this data. I have a bunch of other forms with grids that access "storage grids" via FormulaCell types. I am starting to see poor performance. What general things can I do to improve performance of the grids? For example on one form I have a long grid that I need to scroll on. If I scroll to fast, the form cannot keep up.

thanks



Administrator [Syncfusion]
Replied On March 10, 2008 09:39 PM UTC

Hi Paul,

Thank you for your interest in Syncfusion products.

Please try setting this property to improve grid performance.

OptimizeDrawBackground - This combines cells that have the same background, to be drawn with one paint operation instead of drawing the background for each cell individually.

OptimizeInsertRemoveCells - This lets you specify that the inserting and removing of cells should be optimized, by scrolling the window contents and only invalidating new cells instead of redrawing the whole display.

SupportsPrepareViewStyleInfo - By default, the grid will make a copy of any style object before painting and will call the "PrepareViewStyleInfo" event. Changes that are made to the style object will then be discarded after the painting. The same is with the "DrawCell" and other events. Having a copy of the style will allow you to change the style object just for the purpose of drawing. If you do not have any need for this and want to increase the scrolling performance of the grid, then try setting this property to false.

Please refer the below browser samples that will give you some idea about how to improve grid performance.
Grid.Windows-->PerformanceSamples-->OneTimeOnlyQueryCellInfo
Grid.Windows-->PerformanceSamples-->RefreshGrid
Grid.Windows-->PerformanceSamples-->TraderGridTest

Please let me know if this helps.

Regards,
Srirajan



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;