We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy.
Unfortunately, activation email could not send to your email. Please try again.

StackingColumn Series Type Problem

Thread ID:

Created:

Updated:

Platform:

Replies:

72060 Feb 29,2008 02:52 AM Mar 2,2008 11:54 PM WPF 3
loading
Tags: Chart
grif
Asked On February 29, 2008 02:52 AM

Hello, I'm playing with the Essential Chart for a few days. Today I've discovered a problem with the stacking columns chart. In the attached file you could see a chart with two series of StackingColumn type. I assume that the result is not correct (there are breaks between the series). Have you any ideas how to solve the problem?



untitled.zip

Administrator [Syncfusion]
Replied On February 29, 2008 04:52 AM

Hi Grif,

I have analyzed the screenshot attached by you. I believe that the output mentioned in the attached image occurs only when you have three ChartSeries with Stroke and interior properties of second ChartSeries is set Transparent respectively.

If this is not scenario that causes you the issue then kindly mention the ChartSeries data so that I could help you overcome this issue.

Let me know if you have further queries.

Thanks for your interest in Syncfusion products.

Regards,
Athaur Rahman GS



grif
Replied On February 29, 2008 08:57 AM

Thanks for the quick response.


> I believe that the output mentioned in the attached image occurs only when you have three ChartSeries with Stroke and interior properties of second ChartSeries is set Transparent respectively.


No, there are only 2 ChartSeries added to the ChartArea.


I guess I've found the cause of the problem. The problem occurs when data passed as XAxis is not sorted (i.e. when I pass a DataView as a Source for ChartBindingData object and the DataView content is not sorted by the column that is set as ChartBindingData.XPath).


I hope this feature will be fixed or will be added to the knowledge base.



Regards,

Grigory




Administrator [Syncfusion]
Replied On March 2, 2008 11:54 PM

Hi Grigory,

Thanks for the update. My analysis was limited since I didn't had enough information about the issue except for the screenshot. I had verified the scenario mentioned by you and came to conclusion that it is a defect. I have logged an issue to the developers regarding this and it will be fixed soon.

Let me know for further queries.

Thanks for your interest in Syncfusion products.

Regards,
Athaur Rahman



CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.

;