We use cookies to give you the best experience on our website. If you continue to browse, then you agree to our privacy policy and cookie policy. (Last updated on: November 16, 2018).
Unfortunately, activation email could not send to your email. Please try again.
Syncfusion Feedback

Why the cell does not blink right after validation

Thread ID:

Created:

Updated:

Platform:

Replies:

71089 Jan 15,2008 07:59 AM UTC Jan 30,2008 07:29 PM UTC WinForms 2
loading
Tags: GridControl
John Ruiz
Asked On January 15, 2008 07:59 AM UTC

One of the cell is configured to blink every time there is a change in the cell.

I'd like the cell to blink right when the user edit's the cell and hits key. For some reason clicking tab would invoke the cell validation but not blink when I do e.cancel=false;. It blinks when it has focus to some other cell?

Please suggest if i am missing something. I can not call confirmchanges function from validation function as it will recursively call the same



John Ruiz
Replied On January 21, 2008 01:15 PM UTC

Guys,

Almost a week i posted this question. Please can any one answer me?


haneefm [Syncfusion]
Replied On January 30, 2008 07:29 PM UTC

Hi John,

The comment is that calling the ConfirmChanges method does set up the possibilty of recursive calls to CurrentCellValidating event handler. ConfirmChanges method calls CurrentCellValidating so if your CurrentCellValidating calls ConfirmChanges, then you can get in a loop. But this could be handled by setting a flag, or tightly controlling when you call ConfirmChanges in CurrentCellValidating.

Please refer to the below forum thread for bilking cells in a grid.
http://www.syncfusion.com/support/forums/message.aspx?&MessageID=68681

Best regards,
Haneef


CONFIRMATION

This post will be permanently deleted. Are you sure you want to continue?

Sorry, An error occured while processing your request. Please try again later.

Warning Icon You are using an outdated version of Internet Explorer that may not display all features of this and other websites. Upgrade to Internet Explorer 8 or newer for a better experience.Close Icon

;